W3C home > Mailing lists > Public > www-jigsaw@w3.org > March to April 2000

Jdk1.2 required for 2.0.4?

From: Niklas Wiberg <e95_nwi@it.kth.se>
Date: Wed, 22 Mar 2000 18:06:39 +0100
Message-ID: <38D8FD9F.712E0A3C@it.kth.se>
To: www-jigsaw@w3.org
Hi
Is jdk1.2 required in order to run recent devel versions jigsaw 2.0.4?
I previously used the release from 20000121 using jdk1.1.7, but now it
seems as if the 2.0.4 from 20000317 (devel) makes use of
java.io.File.listFiles(), which is a jdk1.2 only method. I think it's
called from org.w3c.util.IO.clean(). (I can't find that method at all in
the 20000121 source...)

Is this a mistake (bug) which will be corrected or am I doomed to use
the older 2.0.4 release until I can make use of a 1.2 JDK?
There are some things that makes it impossible for me to use a 1.2 JDK
right now :(

Is it possible to download the source for the 20000317 version? Perhaps
I could make use of the improvements while trying to work around the 1.2
requirement if I had the source...?

Best regards
Niklas Wiberg
Received on Wednesday, 22 March 2000 12:10:16 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 5 February 2014 07:14:07 UTC