W3C home > Mailing lists > Public > www-jigsaw@w3.org > May to June 1999

Re: Using Jigsaw as proxy to another proxy ?

From: Yves Lafon <ylafon@w3.org>
Date: Tue, 25 May 1999 22:22:24 +0200 (MET DST)
To: rob sanders <rsanders@draper.com>
cc: "www-jigsaw@w3.org" <www-jigsaw@w3.org>
Message-ID: <Pine.GSO.4.10.9905252221360.1253-100000@tarantula.inria.fr>
On Tue, 25 May 1999, rob sanders wrote:

> I read the suggestions and tried again to access my servlet as described
> with an unmodified ProxyFrame. 
> 
> Proxying works, but local servlet activation doesn't seem to work in
> the  proxy-configured server. 
> 
> Perhaps because the root resource is pointing to the framed resource for
> the ProxyFrame the server can't find the servlet directory.
> 
> To execute local servlets, I have to:
>  Run JiAdmin-->Goto Properties frame-->Click on general button
>  change "Root Name" parameter from "proxy" to "root"
>  save admin properties, restart server
> 
> Then the servlets are found and work, but proxying is disabled. 
> 
> Any guesses at potential workaround strategies?

It may be a bug due to a shift in the path to the servlet, we will look
into that.

      /\          - Yves Lafon - World Wide Web Consortium - 
  /\ /  \        Architecture Domain - Jigsaw Activity Leader
 /  \    \/\    
/    \   /  \   http://www.w3.org/People/Lafon - ylafon@w3.org    
Received on Tuesday, 25 May 1999 16:22:29 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 9 April 2012 12:13:29 GMT