W3C home > Mailing lists > Public > www-jigsaw@w3.org > July to August 1999

RE: Virtual Hosts disappearing under NT

From: Bret Holstein <bret@grizzlys.com>
Date: Wed, 28 Jul 1999 13:26:47 -0400 (EDT)
To: <www-jigsaw@w3.org>
Message-ID: <NCBBJKDMNKOENIMGONNFKEIACGAA.bret@grizzlys.com>
Hmmm, I just downloaded 2.0.3 for this NT workstation yesterday.  Previously
I did not have Jigsaw on the system where I am now experiencing the problem.
I tried it again using PassDirectory with a directory under my Jigsaw\Jigsaw
directory as the pass-target.  That worked fine in all respects.  When I
changed the pass-target to a directory on the same local partition but not
under this directory I get the following error:
Document not found
The document http://coolgraphics:8001/ is indexed but not available.
The server is misconfigured.
With subsequent tries coming from the document root instead of the
partition...

I am logged in as the Administrator for the Workstation - so access
shouldn't be a problem (as this is a personal development system, I don't
log in as anyone else) - and the drive is a local partition.

Is there anything else I can add that might help?

Thanks!

-----Original Message-----
From: www-jigsaw-request@w3.org [mailto:www-jigsaw-request@w3.org]On Behalf
Of Yves Lafon
Sent: Wednesday, July 28, 1999 9:59 AM
To: Bret Holstein
Cc: www-jigsaw@w3.org
Subject: Re: Virtual Hosts disappearing under NT

On Tue, 27 Jul 1999, Bret Holstein wrote:

> I have been experimenting with virtual hosts under both Unix and NT.  The
> Unix setup went without a hitch.  However, the NT virtual servers seem to
> disappear after the first time they are accessed.
>
> The first time I try to access 'coolgraphics:8001' after it has been setup
> and saved (PassDirectory, HTTPFrame, paths set etc.) I get a message
saying
> it is '...indexed but unavailable...'  with subsequent accesses producing
> the 'root' pages.  I then note there is an entry in the error log that
says:
>
> org.w3c.jigsaw.resources.PassDirectory@/: coolgraphics:8001: deleted,
> removing the DirectoryResource
>
> When setting this virtual host up I noted that the 'Index' attribute under
> the HTTPFrame would not show me a list of files (even after reindexing)
> although my pass-target for the PassDirectory resource was set correctly
> ('e:\Inetpub\wwwroot\')
>
> I didn't have this problem with the UNIX setup.  What is going on?

There was a problem in Jigsaw 2.0.2 and earlier with modified root
resource. However, a virtual host should not disappear. However, if the
PassDirectory target is no longer available (or you don't have the right
to access it), then it will be deleted. If your directory was a connected
drive, unavailable at the time you tried to access the URI, it may be the
answer.
Regards,

      /\          - Yves Lafon - World Wide Web Consortium -
  /\ /  \        Architecture Domain - Jigsaw Activity Leader
 /  \    \/\
/    \   /  \   http://www.w3.org/People/Lafon - ylafon@w3.org
Received on Wednesday, 28 July 1999 15:00:40 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 9 April 2012 12:13:32 GMT