W3C home > Mailing lists > Public > www-jigsaw@w3.org > July to August 1998

Unable to click on the root icon

From: mathieu philippe <mathieu@lifl.fr>
Date: Mon, 31 Aug 1998 07:28:50 -0400 (EDT)
Message-Id: <3.0.5.32.19980829115331.007b8100@popper.lifl.fr>
To: www-jigsaw@w3.org
I want to use Jigsaw server on my personal computer at home 
(to try my servlets at home before running them at work)
but i have two problems.

I)

On my computer i have an "Auomatic IP adress" to connect to my provider
Unfortunately when i run Jigsaw i obtain :

> java org.w3c.jigsaw.Main -root \progra~1\Jigsaw\Jigsaw
loading properties from: \progra~1\Jigsaw\Jigsaw\config\server.props
Unable to launch http-server:
org.w3c.jigsaw.http.httpd[initializeProperties]: [host] undefined.
Unable to launch admin-server:
org.w3c.jigsaw.admin.AdminServer[initializeProperties]: [host] undefined.
*** FATAL Error:
No servers launched !

thus i chanched my configuration to put a fixed (arbitrary) IP adress, and
then it works.

Why Jigsaw can't work with an automatic IP adress like other servers like
IIS ?


II)

After having running my Jigsaw server, i obtain

> java org.w3c.jigsaw.Main -root \progra~1\Jigsaw\Jigsaw
loading properties from: \progra~1\Jigsaw\Jigsaw\config\server.props
Jigsaw[2.0beta2]: serving at http://phiphi:8001/
*** Warning : no logger specified, not logging.
JigAdmin[2.0beta2]: serving at http://phiphi:8009/

All seems to be OK

i try now to run the administrator tool

> java org.w3c.jigadm.Main -root \progra~1\Jigsaw\Jigsaw http://phiphi:8009/

the Autorization window appears and i enter admin/admin
the root icon appears but when i want to click on it ...

Exception occurred during event dispatching:
java.lang.IllegalAccessError: try to access method
org/w3c/tools/widgets/TreeBro
wser.itemAt(I)Lorg/w3c/tools/widgets/TreeNode; from class
org/w3c/tools/widgets/
TreeBrowser$BrowserMouseListener
        at
org.w3c.tools.widgets.TreeBrowser$BrowserMouseListener.mouseClicked(T
reeBrowser.java)
        at java.awt.Component.processMouseEvent(Component.java:2716)
        at java.awt.Component.processEvent(Component.java:2556)
        at java.awt.Component.dispatchEventImpl(Component.java:2041)
        at java.awt.Component.dispatchEvent(Component.java:1951)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:167)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:45)


Where are my mistakes ?
What must i do ?
Does it comes from my JDK version ?


III)
Sometimes, when i run the admin tool it crash immediately with the message

<C:\WINDOWS\Fonts\EUCARON.TTF> of 71424, ln 1360, rd 0, sz 75956, tell
71424, er
r 0

Do you have an idea about that ?


IV)

here is my configuration:
Pentium Pro 200MhZ, 32 Mo Ram
Windows 95 4.00.950a
JDK 1.2 Beta 3
CLASSPATH=.;c:\progra~1\jigsaw\classes\jigsaw.zip


PM
mathieu@lifl.fr
Received on Monday, 31 August 1998 10:51:35 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 9 April 2012 12:13:28 GMT