W3C home > Mailing lists > Public > www-jigsaw@w3.org > July to August 1998

Re: Wow![HELP] Configuring Jigsaw2.0beta1 using JigAdm for Servlets and cgi-bin

From: Tarang Kumar Patel <mombasa@ptolemy.arc.nasa.gov>
Date: Wed, 1 Jul 1998 15:01:09 -0400 (EDT)
Message-Id: <199807011859.LAA11869@kilimanjaro.arc.nasa.gov>
To: akapadia@seastore.jpl.nasa.gov
CC: www-jigsaw@w3.org
>>>>> On Tue, 30 Jun 1998 16:29:19 -0700, Apu Kapadia <akapadia@seastore.jpl.nasa.gov> said:

    Apu> Wow,

    Apu>   You won't believe it, but I'm doing exactly the same thing and I'm
    Apu> stuck at exactly the same problem. Freaky. I tried using the
    Apu> SnoopServlet in JSDK2.0 for the first test, and got the same error. I
    Apu> can't seem to fix it. Have you figured out a way? Please let me know!

    Apu> Thanks, Apu.

 Do have the same problem with running a CGI script ?

 i.e did you configure the Resource (using Jiadm) to id the CGI directory
      with the addition of frames of class "org.w3c.jigsaw.frames.CgiFrame
     and then placing a cgi script in the CGI directory and attempting to
     use it from your browser.

 Currently I am re-compiling Jigsaw, having actived the SSI elements of the
 code, which are commented out in the SOURCE.

 If you are planning to do this then watch out for the following

    1) Must define TARGET, as else the class files will be compiled in the
       same source directory and then no way of cleanly creating "jigsaw.zip" 
       unless you write a script.
  
       cd ${HOME}/Jigsaw
       gmake JAVAFLAGS=-deprecation MAKEDIR=${HOME}/Jigsaw/src/makefiles TARGET=${HOME}/Jigsaw/classes 

    2) Source files in "org/w3c/jigsaw/indexer" address "package w3c...."
 
       Need to replace "w3c" with "org.w3c" in all the files in this
       directory.

    3) It appears that the source in org/w3c/jigsaw/servlet/ makes use of
       the java extensions class "javax.servlet" as released in JSDK1.2
       - or just their is coding error and one needs to implement the method

      public String getCharacterEncoding()

      in "JigsawHttpServletRequest.java". I concluded the later, as JSDK1.2
      is still in beta testing.

      The reason for this is clear when you look at documentation
       JSDK2.0/apidoc/javax.servlet.ServletRequest.html#_top_
      and compare that of "javax.servlet" from 

     http://www.javasoft.com/products/jdk/1.2/docs/api/javax.servlet.ServletRequest.html

    JSDK2.0 has class files that are already deprecated in JDK1.2


   Or you could wait out the hassle and I'll get a feed back of my attempts to
   get this working.

   Unfortunately I've had little response from www-jigsaw on this very basic
   problem.

    Tarang


    >> [HELP] Configuring Jigsaw2.0beta1 using JigAdm for Servlets and cgi-bin
    >> 
    >> Tarang Kumar Patel (mombasa@ptolemy.arc.nasa.gov) Wed, 24 Jun 1998
    >> 20:37:50 -0400 (EDT)
    >> 
    >> * Messages sorted by: [ date ][ thread ][ subject ][ author ] * Next
    >> message: Yves Lafon: "Re: [mombasa@ptolemy.arc.nasa.gov: [Q]
    >> Jigsaw2.0beta1 release and servlets ?]"  * Previous message: Toshiki
    >> Murata: "jdbm's patch --- bug fix and performance improvement"
    >> 
    >> ----------------------------------------------------------------------
    >> 
    >> Date: Wed, 24 Jun 1998 20:37:50 -0400 (EDT) Message-Id:
    >> <199806250036.RAA15417@kilimanjaro.arc.nasa.gov> From: Tarang Kumar
    >> Patel <mombasa@ptolemy.arc.nasa.gov> To: www-jigsaw@w3.org,
    >> Benoit.Mahe@sophia.inria.fr cc: mombasa@ptolemy.arc.nasa.gov Subject:
    >> [HELP] Configuring Jigsaw2.0beta1 using JigAdm for Servlets and cgi-bin
    >> 
    >> Hi,
    >> 
    >> I've followed the advice on this channel as well as reworked
    >> documentation that Benoit has faciliated as:
    >> 
    >> http://www.w3.org/Jigsaw/Doc/User/servlets.html
    >> 
    >> However I can't get the server to respond and infact I get the
    >> following exception :
    >> 
    >> java.lang.IllegalAccessError: Unimplemented interface method at
    >> org.w3c.jigsaw.servlet.ServletWrapper.service(ServletWrapper.java) at
    >> org.w3c.jigsaw.servlet.ServletWrapperFrame.perform(ServletWrapperFrame.java)
    >> at
    >> org.w3c.tools.resources.FramedResource.performFrames(FramedResource.java)
    >> at org.w3c.tools.resources.FramedResource.perform(FramedResource.java)
    >> at org.w3c.jigsaw.http.httpd.perform(httpd.java) at
    >> org.w3c.jigsaw.http.Client.processRequest(Client.java) at
    >> org.w3c.jigsaw.http.Client.startConnection(Client.java) at
    >> org.w3c.jigsaw.http.socket.SocketClient.run(SocketClient.java) at
    >> org.w3c.util.CachedThread.run(ThreadCache.java)
    >> 
    >> My system being an SGI running IRIX6.2 and JDK1.1.3.
    >> 
    >> To summize the configuration in Jigadm, I did the following steps on
    >> the tree browsed by the admin tool.
    >> 
    >> 0) md Jigsaw/Jigsaw/WWW/Servlets (my preference)
    >> 
    >> 1) copied SnoopServlet.class to Jigsaw/Jigsaw/WWW/Servlets/
    >> 
    >> start JigAdm 2) open "Root", "http-server" folders 3) open "space"
    >> folder 4) open "Servlets" folder 4) Add Frame of class
    >> "org.w3c.jigsaw.servlet.ServletDirectoryFrame" to my "Servlets"
    >> directory resource, thus
    >> 
    >> Servlets |_______ServletDirectoryFrame (frame-0)
    >> 
    >> 5) Added a "Snoop" identifier of class
    >> "org.w3c.jigsaw.servlet.ServletWrapper" with the servlet-class:
    >> SnoopServlet
    >> 
    >> thus
    >> 
    >> Snoop |_______ServletwrapperFrame (servlet-wrapper-frame)
    >> 
    >> 6) Having committed the settings at the required stages, and further
    >> saving the setting from "Control" file.
    >> 
    >> I restarted the server and proceeded to
    >> 
    >> http://my-server-host:port/Servlets/Snoop
    >> 
    >> Thats when I get the above exception.
    >> 
    >> What's the problem ?
    >> 
    >> Finally, I can't get even seem to get any of my cgi scripts in the
    >> "cgi-bin" directory to work. I configured the "cgi-bin" folder under
    >> "space" with addition of a have "org.w3c.jigsaw.frames.CgiFrame"
    >> 
    >> So when I invoke
    >> 
    >> http://my-server-host:port/cgi-bin/counter.pl/xyz?-i I get served up
    >> with the Directory view of the "cgi-bin" with 1 file "empty.txt". I do
    >> not see the cgi scripts in that directory even though there are clearly
    >> installed under that directory.
    >> 
    >> HELP, HELP... as I've spent some time on this and now am at a dead end.
    >> 
    >> Your help is appreciated.
    >> 
    >> Tarang
    >> 
    >> 
    >> ----------------------------------------------------------------------
    >> 
    >> * Messages sorted by: [ date ][ thread ][ subject ][ author ] * Next
    >> message: Yves Lafon: "Re: [mombasa@ptolemy.arc.nasa.gov: [Q]
    >> Jigsaw2.0beta1 release and servlets ?]"  * Previous message: Toshiki
    >> Murata: "jdbm's patch --- bug fix and performance improvement"
Received on Wednesday, 1 July 1998 16:23:57 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 9 April 2012 12:13:27 GMT