W3C home > Mailing lists > Public > www-jigsaw@w3.org > January to February 1998

Beta1.0b under OS/2

From: Russell Steven Shawn O'Connor <roconnor@wronski.math.uwaterloo.ca>
Date: Sun, 15 Feb 1998 23:36:17 -0500 (EST)
To: www-jigsaw@w3.org
cc: jigsaw@w3.org
Message-ID: <Pine.SOL.3.95q.980215232529.3209B-100000@wronski.math.uwaterloo.ca>

Okay after failing to install the zip file under 2 different sytems, I've
installed Jigsaw from the tar-gzip version.  

The sever is having some problem under OS/2 Warp 4.

[E:\monarch]java -version
JAVA.EXE version "JDK 1.1.4 IBM build o114-19971121"

When I try using Netscape or IBM web explorer to connect I sits waiting
fro a response, then times out.  I installed jigsaw under Windows 95
running jdk1.1.5, and it worked fine.

So I did futher investigation under the OS/2 version.  I used telnet and
found that

GET / HTTP/1.0 

appeared to work fine, however if I tried to add any headers:

GET / HTTP/1.0
Host: localhost:8001

the server fail to respond and just hung there.  Jigsaw\Jigsaw\logs\errlog
has errors like the following listed:

client-1(socket-clients:20): caught ClientException:
[w3c.jigsaw.http.ClientException] expecting :(58) got(-1)
context:

I'm a little under whenter it is expection ':' (58) or 'X' (0x58).  ':'
would make the most sense.  However I sent pleanty of :'s.

I guess this mean I should go poking around the code.  Maybe I should try
compiling all the class files on my system.

Any suggestions would be appreaciated.

-- 
Russell O'Connor                           roconnor@uwaterloo.ca
    <URL:http://www.undergrad.math.uwaterloo.ca/%7Eroconnor/>
"And truth irreversibly destroys the meaning of its own message"
-- Anindita Dutta, "The Paradox of Truth, the Truth of Entropy"
Received on Sunday, 15 February 1998 23:36:43 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 9 April 2012 12:13:27 GMT