W3C home > Mailing lists > Public > www-jigsaw@w3.org > July to August 1997

Salvager resource and browser's cache

From: Frederic Crozat ISIMA <crozat@opgc16.univ-bpclermont.fr>
Date: Fri, 22 Aug 1997 15:29:24 +0200
Message-Id: <9708221329.AA03576@opgc16.univ-bpclermont.fr>
To: www-jigsaw@w3.org
Hi,

I've encounter a little problem with the Salvager resource and some browsers
(IE and Netscape) when I try to see the status of the Salvager resource 
(http://host/Admin/Salvager). Often, when I try to refresh the page, my
browser keeps showing the old one and doesn't connect to Jigsaw. It uses its
own caching scheme (it is set to check pages only one time per session)
but it should check it if I reload it but it refuses. 

I've added the following "no caching" code (from tutorial) at the end of
the SalvagerResource source :
public Reply createDefaultReply(Request request, int status) {
        Reply reply = super.createDefaultReply(request, status);
        reply.setNoStore(true);
        // Be friendly to HTTP/1.0 caches too:
        reply.addPragma("no-cache");
        return reply;
    }

and the problem is gone !! 

I'm currently using Jigsaw alpha 5 and I think you should add this to
next beta version.

I've also seen in the httpd source that the default timeout values given
in the "api" file aren't those used in the code. For example, Keep_Alive
Timeout is supposed to be 10000 ms but in the code, it's 1200000 !!
Which values are correct ? 

Thanks in advance and I'm impatient to see next version of Jigsaw.

Frederic Crozat
Observatoire de Physique du Globe de Clermont-Ferrand / France
crozat@opgc.univ-bpclermont.fr
Received on Friday, 22 August 1997 09:27:54 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 9 April 2012 12:13:26 GMT