W3C home > Mailing lists > Public > www-jigsaw@w3.org > January to February 1997

Filter removal problem

From: Jason Hoos <jhoos@math.uiuc.edu>
Date: Thu, 30 Jan 1997 17:37:03 -0600 (CST)
Message-Id: <199701302337.RAA11119@orion.math.uiuc.edu>
To: www-jigsaw@www10.w3.org
Cc: jhoos@math.uiuc.edu
Ok, here's a really strange problem (in my opinion at least).

I'm currently running a Jigsaw 1.0a3 server.  For this server I have
written a resource which, among other things, has the ability to 
delete filters off of other resources.  However, there seems to be
some major discontinuities between what I'm doing and what /Admin/Editor
says I'm doing.

This is the method I'm using to delete:
1. Look up the resource.
2. Obtain the list of filters from the resource using getFilters().
3. Scan that list for a filter with a given name.
4. Obtain the target of the filter with filter.getTargetResource.
5. Call unregisterFilter(filter) on the obtained target.

(I've also tried the direct method of just calling unregisterFilter
on the resource I got in step one instead of using getTargetResource;
it didn't change anything.)

Anyhow, here's a play-by-play of what happens.
1. I start the Jigsaw server, use a nice non-caching (I think) browser
like Lynx to look at the /Admin resource in /Admin/Editor.  It happily
asks for authentication information and then shows me my filter as
"filter-0" on the list at the bottom of the form editor.
2. I then tell my resource to nuke the aforementioned filter on /Admin.
3. I kill lynx and then do step 1 again.  It goes straigt into /Admin/Editor
without asking for authentication information, implying that the filter
is indeed dead.  However, the 'filter-0' entry is still listed in the
editor!
4. I then checkpoint the server from /Admin/Properties, and doing
step 1 yet again.  Same result as in step 3.
5. Being ever persistent, I then restart the server from /Admin/Properties.
Now, when I try step one, I get a NullPointerException in line 558
of SimpleResourceStore.enumerateResourceIdentifiers when I try to get
into /Admin/Editor! 
6. Finally, as a last ditch attempt, I kill the server with /Admin/Exit.
I then try step one again.  This time, finally, everything is happy,
my filter is dead, /Admin/Editor concurs that my filter is dead, and
I'm pleased except for having had to kill the server.

Anyhow, I suspect I'm either not properly deleting the filter, or
I'm getting bitten by some bizarre in-server caching bug.
Anyone have any ideas for me?

Jason Hoos
jhoos@ncsa.uiuc.edu
Received on Thursday, 30 January 1997 18:37:31 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 9 April 2012 12:13:26 GMT