W3C home > Mailing lists > Public > www-jigsaw@w3.org > July to August 1996

more Old CGI stuff.

From: Walter Truitt from SPD <wtruitt@sun004.atm.dsccc.com>
Date: Wed, 24 Jul 1996 11:45:28 -0500 (CDT)
Message-Id: <199607241645.LAA07476@sun032.CPDSC>
To: www-jigsaw@w3.org
Hello group.

I have read through most messages in the archive.  I still have not
been successful in getting a script to run.  Here is my script:

sun032% cat /homes/wtruitt/Jigsaw/Jigsaw/WWW/cgi-bin/howdy.cgi
print "Content-type: text/html\n\n";
print "<html>\n";
print "<head>\n";
print "<title>Hello world with Perl</title>\n";
print "</head>\n";
print "<body>\n";
print "<h1>Hello world with Perl</h1>\n";
print "<p>Howdy, world!</p>\n";
print "</body>\n";
print "</html>\n";

When I run it from the prompt it prints out the stuff like you would

sun032% /homes/wtruitt/Jigsaw/Jigsaw/WWW/cgi-bin/howdy.cgi
Content-type: text/html
<title>Hello world with Perl</title>
<h1>Hello world with Perl</h1>
<p>Howdy, world!</p>

OK, so following the directions, 
1) I made the script and put it under the WWW/cgi-bin directory. 
2) browser -> http://sun032.atm.dsccc.com:8080/Admin/Editor/cgi-bin
3) follow link -> AddingResources
4)   name: mycgitest
5)  class: w3c.jigsaw.forms.CgiResource
6) click ok
7) follow link -> ExistingResources
8) follow link -> mycgitest
9) in command, type ->
(with the return after just in case)
10) in generates form -> false
(I tried both, but anyways)

11) now browser ->

<h1>Document not found</h1><p>The document /cgi-bin/mycgitest is
indexed but not available.<p>The server is misconfigured.

So anyways, I know it finds it and all, it just doesn't run it the
way I expect.

Also, whats the way to subscribe?


Received on Wednesday, 24 July 1996 12:45:47 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:25:29 UTC