W3C home > Mailing lists > Public > www-html@w3.org > September 2000

Alignments for Table behave strange in NN4

From: Lohengrin <lohengrin@hkguy.com>
Date: Wed, 27 Sep 2000 20:47:51 +0800
Message-ID: <002b01c02881$26f4bf00$13700a3d@helloworld.com>
To: <www-html@w3.org>, <www-style@w3.org>
Although I understand that Netscape Navigator 4 is not fully compliant for
HTML 4.01 and CSS2, I'm very disappointed for its inconsistent behaviours.
Here's one example that has taken half of my day. There're 2 simple tables
with the same codes except that one contains </TH>, </TD> while another
doesn't. (I sometimes add them in order to remove the extra white space
following the cell). However, they behave different. I don't know why or if
there's any syntax problem in my codes.

<META http-equiv="Content-Style-Type"
<TITLE>Table Alignment</TITLE>
<STYLE type="text/css">
.num {
    text-align: right;
    font-family: "Courier New", Courier, monospace;
<H1>Table Alignment</H1>
<DIV style="text-align: center;">
  <TABLE  width="400"
  <CAPTION>Table 1: Cells not closed with &lt;/TH&gt; and
    <COL span="3">
      <TH>Cell 11
      <TD><P class="num">Cell 12</P>
      <TD class="num">Cell 13
      <TH>Cell 21
      <TD><P class="num">Cell 22</P>
      <TD class="num">Cell 23
      <TH>Cell 31
      <TD><P class="num">Cell 32</P>
      <TD class="num">Cell 33
<DIV  style="text-align: center;">
  <TABLE width="400"
  <CAPTION>Table 2: Cells closed with &lt;/TH&gt; and &lt;/TD&gt;</CAPTION>
    <COL span="3">
      <TH>Cell 11</TH>
      <TD><P class="num">Cell 12</P></TD>
      <TD class="num">Cell 13</TD>
      <TH>Cell 21</TH>
      <TD><P class="num">Cell 22</P></TD>
      <TD class="num">Cell 23</TD>
      <TH>Cell 31</TH>
      <TD><P class="num">Cell 32</P></TD>
      <TD class="num">Cell 33</TD>
No spam
No rumour
No chain letter
No advertisement
No executable
Received on Wednesday, 27 September 2000 08:45:29 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 15:05:54 UTC