W3C home > Mailing lists > Public > www-forms@w3.org > October 2009

Re: Inserting attributes from one instance to another

From: Winona Salesky <wsalesky@gmail.com>
Date: Fri, 23 Oct 2009 09:45:17 -0400
Message-ID: <8ee07d540910230645k2e6d6c34x132a1deb3f583b0f@mail.gmail.com>
To: Charles F Wiecha <wiecha@us.ibm.com>
Cc: www-forms@w3.org, www-forms-request@w3.org
Sorry, that is just a cut and past issue. This code works in Orbeon, and I
believe it used to work with the firefox extension, but I'm not sure when it
stopped working.
-Winon

On Fri, Oct 23, 2009 at 8:55 AM, Charles F Wiecha <wiecha@us.ibm.com> wrote:

> Do you have an extra blank in your context xpath or is that just a
> cut&paste issue? Charlie Wiecha
>
>
> [image: Inactive hide details for Winona Salesky ---10/23/2009 08:11:13
> AM---I've been using the firefox extntion for a while and you]Winona
> Salesky ---10/23/2009 08:11:13 AM---I've been using the firefox extntion for
> a while and you used to be able to insert attributes from
>
>
> From:
> Winona Salesky <wsalesky@gmail.com>
> To:
> www-forms@w3.org
> Date:
> 10/23/2009 08:11 AM
> Subject:
> Inserting attributes from one instance to another
> Sent by:
> www-forms-request@w3.org
> ------------------------------
>
>
>
> I've been using the firefox extntion for a while  and you used to be able
> to insert attributes from one instance to another using the following
> syntax:
>  <xforms:trigger appearance="minimal" ref="self::node()[not(@type)]">
>     <xforms:label>Add type</xforms:label>
>      <xforms:insert ev:event="DOMActivate"
> context="instance('metadata')//mods:mods/
> mods:titleInfo[index('titleInfo')]"
>            origin="instance('template')/mods:titleInfo/@type"/>
> </xforms:trigger>
>
>
> This does not appear to work anymore, is my syntax wrong, or is this no
> longer supported?
>
> Thanks.
>
> -Winona
>
>



ecblank.gif
(image/gif attachment: ecblank.gif)

graycol.gif
(image/gif attachment: graycol.gif)

Received on Friday, 23 October 2009 13:51:24 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Saturday, 10 March 2012 06:22:18 GMT