W3C home > Mailing lists > Public > www-forms@w3.org > July 2002

Button control should be called command control

From: Werner Donné <werner.donne@re.be>
Date: Wed, 24 Jul 2002 18:34:42 +0200
Message-ID: <3D3ED722.9060205@re.be>
To: www-forms@w3.org


The form controls in XForms are abstract, i.e. an XForms implementation
is free in mapping them to actual GUI elements, so long as the specified
XForms behaviour is adhered to. A selectOne control, for example, can be
implemented as a listbox, a checkbox, etc.

I therefore think that the name "button" is too narrow for the button control.
Command control or action control are better names because they express
the logical task of the control. It could be implemented with a button, but
also with an item in a popup menu or a keyboard shortcut, or even with
all of these together. Such implementations are, of course, not common in
browsers, but XForms is not limited to such an environment.


Werner Donné  --  Re BVBA
Engelbeekstraat 8
B-3300 Tienen
tel: (+32) 486 425803	e-mail: werner.donne@re.be
Received on Wednesday, 24 July 2002 12:34:19 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:36:06 UTC