W3C home > Mailing lists > Public > www-forms-editor@w3.org > September 2002

8.1.9 - submit element - Design problems?

From: <AndrewWatt2001@aol.com>
Date: Tue, 3 Sep 2002 09:22:44 EDT
Message-ID: <105.1b3dc44f.2aa611a4@aol.com>
To: xforms@yahoogroups.com, www-forms@w3.org, www-forms-editor@w3.org

Bear with me here ... I may very well be missing something obvious ... my 
head is hurting. :)

I am having problems reconciling the design of the submit element in the 
current WD with Requirement 4.3 of the Requirements WD.

Requirement 4.3 indicates that XForms must support multiple "forms" per page. 
As I mentioned in an earlier post it is far from clear what a "form" is in 
the context of XForms.

But let's assume that it means that multiple XForms models are allowed on 
each page. The spec says they are allowed, so it seems a plausible parallel 
to the Requirement.

So far so good. I would expect each xforms:model element may have its own 
xforms:instance element. That provides initialization data for the instance 
data of two different models. So we have two separate trees of instance data 
- if we have two xforms:model elements. Right so far?

But the design of the submit element is that it has single node binding. It 
seems to me that it binds to a single xforms:submission element in a single 
xforms:model. Or did I miss something?

So how can I create a submit scenario which will submit data from more than 
one XForms model - given that xforms:submit supports only single node binding 
and, as far as I can see, only references a single xforms:submission element 
nested in one (of two or more on the page) xforms:model element?

I am hoping I have missed some solution in the current WD.

For a user to hypothetically fill in two "forms" on one page and then find 
they can only submit data from one seems wholly inappropriate.

I will stop here in the hope that someone can point me to a simple solution 
in the spec.

Anyone help me out here?

Andrew Watt
Received on Tuesday, 3 September 2002 09:23:24 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Wednesday, 10 June 2009 18:12:12 GMT