W3C home > Mailing lists > Public > www-dom@w3.org > January to March 2013

Re: Better event listeners

From: <brandon.wallace@yahoo.com>
Date: Thu, 10 Jan 2013 07:38:18 -0600
Message-Id: <96E7B735-E05C-4B60-BBB6-960543278AA3@yahoo.com>
Cc: Anne van Kesteren <annevk@annevk.nl>, Jake Verbaten <raynos2@gmail.com>, Glenn Maynard <glenn@zewt.org>, "www-dom@w3.org" <www-dom@w3.org>
To: Domenic Denicola <domenic@domenicdenicola.com>
> I meant that, if an object with methods were returned, the method should be named "off" as opposed to "cancel" or "stop" etc. Agreed that a function instead of an object is more elegant, however.

I believe it has been mentioned that an object leaves the door open for future enhancements.  Returning only a function limits your options for future enhancements.

Received on Thursday, 10 January 2013 13:38:48 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 20 October 2015 10:46:20 UTC