W3C home > Mailing lists > Public > www-dom@w3.org > April to June 2013

Re: [futures] Add convenience functions for immediate/canceled promises

From: Anne van Kesteren <annevk@annevk.nl>
Date: Wed, 24 Apr 2013 15:01:21 +0100
Message-ID: <CADnb78gcBddA6iy8VbiMkni5Pg0yJfJ8iybq4fmOYXynt32n9A@mail.gmail.com>
To: "Tab Atkins Jr." <jackalmage@gmail.com>
Cc: Domenic Denicola <domenic@domenicdenicola.com>, Brandon Wallace <brandon.wallace@yahoo.com>, "www-dom@w3.org" <www-dom@w3.org>
On Thu, Apr 18, 2013 at 6:03 PM, Tab Atkins Jr. <jackalmage@gmail.com> wrote:
> The naming suggestions are meant to (a) parallel the collection APIs,
> particularly Array, which uses Array.of() as a "simple constructor"
> (really, it's the monadic lifting function), and uses Array.from() as
> the "conversion constructor".  I think these are readable and easy to
> understand, and while there are good arguments for simple copying the
> resolver's method naming, I think it's even better to follow the
> developing naming standard I lay out above.

Where is Array.of() defined?

Also, I missed this email. I thought we had agreed on
accept/resolve/reject, which I've now added:


Received on Wednesday, 24 April 2013 14:01:49 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 20 October 2015 10:46:20 UTC