W3C home > Mailing lists > Public > www-dom@w3.org > January to March 2011

currentTarget / observer

From: Gerd Wagner <wagnerg@tu-cottbus.de>
Date: Thu, 06 Jan 2011 21:48:39 +0100
Message-ID: <4D262AA7.7020709@tu-cottbus.de>
To: www-dom@w3.org
What about replacing the misnomer "currentTarget" by "observer" in the 
Event interface?

This would help avoiding the confusion about the distinction between 
"target" and "currentTarget" as exemplified in the recent post on the 
D3E mailing list cited below.

Regards,
Gerd Wagner

>  So if Web IDL were being used, you could say something like:
>
>     When invoking an EventListener implemented in ECMAScript, its
>     _callback this value_ must be the target of the event.

Not target but currentTarget ;)
Received on Thursday, 6 January 2011 20:54:28 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Friday, 22 June 2012 06:14:07 GMT