W3C home > Mailing lists > Public > www-dom@w3.org > April to June 2011

[Bug 12958] New: 'textinput' event should be renamed to 'input'

From: <bugzilla@jessica.w3.org>
Date: Wed, 15 Jun 2011 18:10:46 +0000
To: www-dom@w3.org
Message-ID: <bug-12958-4009@http.www.w3.org/Bugs/Public/>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=12958

           Summary: 'textinput' event should be renamed to 'input'
           Product: WebAppsWG
           Version: unspecified
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: DOM3 Events
        AssignedTo: schepers@w3.org
        ReportedBy: mounir.lamouri@gmail.com
         QAContact: member-webapi-cvs@w3.org
                CC: mike@w3.org, www-dom@w3.org


The 'input' event as defined in the HTML specifications is widely implemented
[1] but DOM3 Events specify an event named 'textinput' which seems to be
exactly what 'input' event tries to do. Couldn't the spec rename this event to
'input'?

[1] Successfully tested on Gecko, Presto and Webkit. Didn't try IE.

-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
Received on Wednesday, 15 June 2011 18:10:47 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Friday, 22 June 2012 06:14:07 GMT