W3C home > Mailing lists > Public > www-dom@w3.org > April to June 2010

Re: textInput --> beforeInput

From: James Su <suzhe@google.com>
Date: Mon, 21 Jun 2010 15:37:44 -0700
Message-ID: <AANLkTinuRaFta_AH36y4ZzvrkS697a9JQxorNdH0SRAc@mail.gmail.com>
To: Ojan Vafai <ojan@chromium.org>
Cc: www-dom@w3.org
And can you please tell me where the "input" event is defined officially? I
can only find some very rough description in html5 draft.

在 2010年6月16日 下午5:29,Ojan Vafai <ojan@chromium.org>写道:

> The textInput event should be expanded to include all user-input that
> modifies the DOM. This would match the existing "input" event and make the
> event much more useful. It could then be a catchall event that happens
> before any user-modifications. Basically I'm proposing that:
>
> 1. We add every possible user-action to the list of InputModes (e.g. cut,
> paste, undo, redo, etc.).
> 2. We rename textInput to beforeInput.
> 3. We not fire this event for script operations (matches the existing
> "input" event, is easier to implement and meets all the use-cases that I can
> think of).
>
> Currently, only WebKit implements textInput. It does not yet implement the
> inputMode property. I expect that renaming (or at least aliasing) textInput
> to beforeInput would not be controversial.
>
> Nit: I don't much like "inputMode" as a name. Really it's the user-action
> that it's referring to. I'd rather see inputMode renamed to action, but I
> won't be too upset if we leave it as inputMode.
>
> Ojan
>
Received on Monday, 21 June 2010 22:38:33 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Friday, 22 June 2012 06:14:04 GMT