W3C home > Mailing lists > Public > www-dom@w3.org > January to March 2004

'Re: "method & parameter naming"'

From: Kasimier Buchcik <kbuchcik@4commerce.de>
Date: Mon, 23 Feb 2004 20:29:20 +0100
To: <www-dom@w3.org>
Message-ID: <403A5490.4000709@4commerce.de>

Hi,

on 2/23/2004 8:19 PM Philippe Le Hegaret wrote:

> On Mon, 2004-02-23 at 12:35, Kasimier Buchcik wrote:
> 
>>Hi,
>>
>>My five pence on naming:
>>
>>1. "LSSerializer.parseURI" should be renamed to 
>>"LSSerializer.parseFromURI" - analogous to "LSParser.writeToURI"
>>(I remember that it was changed from "LSParser.writeURI")
> 
> 
> This one seems a bit late to do it but maybe.

Too late is not ok ;-)

>>2. (DOM Level 3) NameList.contains takes a "str", although 
>>NameList.contains takes a "name".
>>Maby NameList.contains(in DOMString name) would be more adequate here.
> 
> 
> The parameter was renamed to match DOMStringList.contains(str),
> following an issue brought but the DOM TS effort:
> http://www.w3.org/2003/12/22-dom-core-issues/issues.html#curt1

Ok.


Greetings,

Kasimier
Received on Monday, 23 February 2004 14:24:42 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Friday, 22 June 2012 06:13:57 GMT