W3C home > Mailing lists > Public > www-dom@w3.org > January to March 2004

"method & parameter naming"

From: Kasimier Buchcik <kbuchcik@4commerce.de>
Date: Mon, 23 Feb 2004 18:35:16 +0100
To: <www-dom@w3.org>
Message-ID: <403A39D4.3080401@4commerce.de>

Hi,

My five pence on naming:

1. "LSSerializer.parseURI" should be renamed to 
"LSSerializer.parseFromURI" - analogous to "LSParser.writeToURI"
(I remember that it was changed from "LSParser.writeURI")

2. (DOM Level 3) NameList.contains takes a "str", although 
NameList.contains takes a "name".
Maby NameList.contains(in DOMString name) would be more adequate here.


Regards,

Kasimier
Received on Monday, 23 February 2004 12:30:49 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Friday, 22 June 2012 06:13:57 GMT