DOM Core Level 1, Node.replaceChild

Dear Editor,

I would suggest the following small change to the Node interface:

	Node replaceChild(in Node newChild, in Node refChild) raises
DOMException;

should be changed to 

	Node replaceChildWith(in Node refChild, in Node newChild) raises
DOMException;

This way, the method name already suggests the right ordering of the
attributes, i.e. the replaced child before the new child. This might prevent
confusion when reading code that uses the DOM. Also, this naming scheme can
be better represented in programming languages that use infix notation, like
Smalltalk. You'd write this as

	replaceChild: oldChild with: newChild

in Smalltalk.

Regards,

Hasko Heinecke

Received on Friday, 25 September 1998 11:08:40 UTC