W3C home > Mailing lists > Public > www-dom-ts@w3.org > February 2003

RE: hc_nodecloneattributescopied has deep="false"

From: Allen, Michael B (RSCH) <Michael_B_Allen@ml.com>
Date: Wed, 26 Feb 2003 23:38:45 -0500
Message-ID: <19B572CFAC42D211A20000805FA7875A07F0FFDD@eat404.hew.us.ml.com>
To: "'Curt Arnold'" <carnold@houston.rr.com>, www-dom-ts@w3.org



> -----Original Message-----
> From:	Curt Arnold [SMTP:carnold@houston.rr.com]
> Sent:	Tuesday, February 25, 2003 12:21 AM
> To:	www-dom-ts@w3.org
> Subject:	RE: hc_nodecloneattributescopied has deep="false"
> 
> 
> Allen, Michael B wrote:
> 
>  >Is this test supposed to have deep="false"? In the description it
>  >says it should be true but the xml file has:
>  >
>  ><cloneNode obj="addressNode" deep="false" var="clonedNode"/>
>  >
>  >PS: Also the order of the expectedResult members is foiling my
>  >assertEqualsList function. Not sure if those are supposed to
>  >appear in order but it would be nice if you could flip them if it
>  >doesn't make any other difference,
> 
> The discrepancy between the test description and the body also appears 
> in nodecloneattributescopied and has apparently been carried over from 
> the original NIST test suite.  This particular test should not be 
> affected by the value of the deep parameter.  Unless there are
> 
	I was just confused for a moment by my deficient assertEqualsCollection.

	Thanks,
	Mike
Received on Wednesday, 26 February 2003 23:39:02 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:34:06 UTC