W3C home > Mailing lists > Public > www-dom-ts@w3.org > February 2002

Re: Documentation and DOMTSL1Core.zip

From: Philippe Le Hegaret <plh@w3.org>
Date: 11 Feb 2002 12:05:23 -0500
To: Curt Arnold <carnold@houston.rr.com>
Cc: www-dom-ts@w3.org
Message-Id: <1013447124.25718.73.camel@jfouffa>
On Mon, 2002-02-11 at 11:14, Curt Arnold wrote:
> > - Once I got the interface, I don't see anything to select. If I put
> > org.w3c.domts.level1.core.TestXerces or ...AltConfig, it keeps saying
> > "failed to invoke suite():java.lang.NoSuchMethodError". I do have
> > xerces.jar in dist/ ...
> >  I looked into dom1-core.jar and this class doesn't seem to exist?
> 
> The first way described to run the tests should be:
> 
> java -jar dom1-core.jar
> 
> Which will run all tests in two modes on the default JAXP parser and print
> results to the console.
> 
> The "TestXerces" and other classes are JUnit specific and therefore are
> located in junit-run.jar.  JUnit's GUIs don't populate the combo box (at
> least for us), but do remember previous entries.
> 
> I haven't seem that message before, it would indicate that the class was
> loaded, but the suite method doesn't exist which should not be the case.
> Any more diagnosis you could provide would be appreciated.

I copied a xerces.jar found in the CVS repository of xerces itself.
After checks, it appears that the jar file didn't contain all the
relevant class files. It worked after using the appropriate xerces.jar.
I tried with Xerces 2.0 but xercesImpl.jar doesn't seem to be the right
jar file to use.

Philippe
Received on Monday, 11 February 2002 12:05:35 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:34:04 UTC