W3C home > Mailing lists > Public > www-annotation@w3.org > January to June 2006

RE: Problems making Rdf makefile when setting up the annotea server in windows.

From: Leddy, Aine <leddy@hp.com>
Date: Tue, 14 Feb 2006 17:33:14 +0000
Message-ID: <D16B9BEDAC43DD42BE0A04905192914C0250351F@dubexc01.emea.cpqcorp.net>
To: "Eric Prud'hommeaux" <eric@w3.org>
Cc: <www-annotation@w3.org>




Hi Eric


The line number was different in different versions, but it always
corresponded to that line of code.

Yes I was using nmake. I'll try and get cygwin and try it with that.

I'll let you know if I have anymore problems.

Thanks 

Aine

-----Original Message-----
From: Eric Prud'hommeaux [mailto:eric@w3.org] 
Sent: 14 February 2006 17:27
To: Leddy, Aine
Cc: www-annotation@w3.org; matthew@mjwilson.demon.co.uk
Subject: Re: Problems making Rdf makefile when setting up the annotea
server in windows.

On Tue, Feb 14, 2006 at 11:00:57AM -0000, Leddy, Aine wrote:
>  
> I am getting the following error when trying to make the makefile in 
> the RDF module.
> 
> makefile(953) : fatal error U1033: syntax error : '=' unexpected Stop.

What make program were you using?

> This corresponds to the following line in the make file
> 
>  YAPPS := $(patsubst %.pm,%.yp,$(PARSERS))

I would not be surprised if nmake does not support this. Though maybe
you were running cygwin?

> This particular version of the RDF module is the most recent CVS 
> version from http://dev.w3.org/cvsweb/perl/modules/W3C/Rdf/
> 
> I originally tried the RDF module that came with annotea-2.tar.gz, 
> there I got the same error. I also tried individual 
> W3C-Rdf-kit-1.tar.gz downloaded from the cspan section of 
> http://www.w3.org/1999/02/26-modules/Distribution.html
> 
> The section of code in the makefile above the line throwing the error 
> seems to be different in each version of the makefile.
> 
> 
> In the cvs version its
> 
> 
> PARSERS = AlgaeParser.pm \
> 	  N3Parser.pm \
> 	  RdalParser.pm \
> 	  RdqlParser.pm \
> 	  SeRQLParser.pm \
> 	  SparqlParser.pm
> 
> In the individual RDF module its
> 
> PARSERS = AlgaeParser.pm \
> 	  RdalParser.pm \
> 	  RdqlParser.pm \
> 	  SeRQLParser.pm \
> 	  TrigParser.pm

Did you get the same error line number for these other versions? I would
expect the same error to always correspond to
    "YAPPS := $(patsubst %.pm,%.yp,$(PARSERS))"

> I am setting up the Annotea server in Windows 2000 if that makes any 
> difference, though all of the other modules downloaded as part of the 
> annotea kit, installed fine. If anyone has come across this or a 
> similar error? Or if anyone has any idea how to go about fixing it, I 
> would appreciate the help. Trying to set up this server has already 
> taken me ages.

Some folks have done this on windows. Could someone say what perl
executable (and package) they used, and whether they ran it under
cygwin?
--
-eric

office: +81.466.49.1170 W3C, Keio Research Institute at SFC,
                        Shonan Fujisawa Campus, Keio University,
                        5322 Endo, Fujisawa, Kanagawa 252-8520
                        JAPAN
        +1.617.258.5741 NE43-344, MIT, Cambridge, MA 02144 USA
cell:   +81.90.6533.3882

(eric@w3.org)
Feel free to forward this message to any list for any purpose other than
email address distribution.
Received on Tuesday, 21 February 2006 23:14:09 GMT

This archive was generated by hypermail 2.2.0+W3C0.50 : Tuesday, 21 February 2006 23:14:10 GMT