W3C home > Mailing lists > Public > www-annotation@w3.org > January to June 2002

Re: Weird Annotea error returned:

From: Jim Ley <jim@jibbering.com>
Date: Mon, 18 Feb 2002 19:41:05 -0000
Message-ID: <064501c1b8b4$351e8060$ca969dc3@emedia.co.uk>
To: <www-annotation@w3.org>
"Jim Ley" <jim@jibbering.com>:
> <Art.Barstow@nokia.com>
>
> > Is the following supposed to be RDF/XML?
>
> Just confirmed that correcting this oversight doesn't change the error
> from the Annotea server.
> http://jibbering.com/2002/2/annotea.rdf has been updated to reflect the
> correct submission.

Okay, with the help of Matthew Wilson, I've corrected that problem (it
needs a PI)

However I now have a new problem:

If I add a Creator  using the 1.1 DC namespace
http://purl.org/dc/elements/1.1/ (I wanted two creators, like the RDFIG
CHUMP->Annotea script at  http://www.w3.org/2001/09/chump/  )  Annotea
goes wrong generating a namespace prefix of 1.1  <1.1:Creator > which my
XML tools certainly can't deal with and don't appear to be valid.  If I
use the 1.0 namespace which Annotea uses internally (shouldn't it being
using 1.1 anyway?) it all works okay.

At a guess Annotea generates the namespace from the uri, which then goes
wrong 'cos of the numbers.

On a side note, here's a gentle reminder about the "application/xml+rdf"
content type bug losing the + when returning it.

(all of this is to do with Storing EARL in Annotea once again, this time
from an IRC bot - which means I also have an IRC client for Annotations.)

Cheers,

Jim.
Received on Monday, 18 February 2002 14:43:08 GMT

This archive was generated by hypermail 2.2.0 + w3c-0.30 : Friday, 25 March 2005 11:19:17 GMT