W3C home > Mailing lists > Public > www-annotation@w3.org > January to June 2001

RE: changing annotation types under Amaya

From: fctmoore <fctmoore@hkusua.hku.hk>
Date: Sun, 20 May 2001 00:09:16 -0400 (EDT)
To: www-annotation@w3.org
Message-ID: <3B073DDB@webmailb.hku.hk>
Dear Colleagues,

   I followed Jose's advice, but it didn't work.  I've probably missed 
something obvious.
   My annot.schemas file in Amaya/config now reads:

# annot.schemas
#
# specifies the RDF schemas to be pre-loaded for Annotations
#
# each line beginning with '#' is a comment
# all other non-empty lines must be in one of two formats:
# 1. namespacename
# 2. namespacename filename
#
# In case 1, an RDF schema is expected to be found at the namespace URI
# In case 2, the filename is expected to be a (local) copy of an RDF
#            schema for the namespace.  The strings $THOTDIR and
#            $APP_HOME may be used at the beginning of the filename
#            and will be expanded to the Amaya installation directory
#            and the user's amaya home directory respectively.

# Historical schema presented at WWW9. Obsolete.
#http://www.w3.org/1999/xx/annotation-ns#

#first release schema; do not change unless you also change the service
http://www.w3.org/2000/10/annotation-ns#  $THOTDIR/config/annotschema.rdf

#some Annotation subclasses that we think will be useful
http://www.w3.org/2000/10/annotationType# $THOTDIR/config/annottypes.rdf

#to add new types (Tim Moore)
http://www.w3.org/2001/05/MyTypes# $THOTDIR/config/mytypes.rdf

I added a new file entitled mytypes.rdf, which reads

<rdf:RDF
   xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
   xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#">

<rdf:Description about="http://www.w3.org/2000/10/MyTypes#">
 <rdfs:comment>A namespace for describing types of annotations</rdfs:comment>
 <rdfs:comment>$Revision: 1.2 $ $Date: 2000/11/03 21:40:17 $</rdfs:comment>
 <rdfs:seeAlso 
resource="http://www.w3.org/2000/02/Collaboration/Annotation/papers"/>
</rdf:Description>

<rdfs:Class rdf:about="http://www.w3.org/2000/10/MyTypes#Kudos">
  <rdfs:label xml:lang="en">Kudos</rdfs:label>
  <rdfs:comment>A class of Annotations representing positive 
congratulations</rdfs:comment>
  <rdfs:subClassOf 
rdf:resource="http://www.w3.org/2000/10/annotation-ns#Annotation"/>
  <rdfs:isDefinedBy resource="http://www.w3.org/2000/10/MyTypes#"/>
</rdfs:Class>

</rdf:RDF>

(This involved departing from Jose's message by adding an initial "<".)

When this did not work upon reinvoking Amaya, I tried changing the MyTypes 
prefix in mytypes.rdf to match the one in annot.schemas, but this did not work 
either.  I have tried this on two separate machines.

I'd be grateful for advice.

Best wishes,

Tim Moore 
Received on Monday, 21 May 2001 01:28:01 GMT

This archive was generated by hypermail 2.2.0 + w3c-0.30 : Friday, 25 March 2005 11:19:17 GMT