W3C home > Mailing lists > Public > www-amaya@w3.org > October to December 2012

Re: problem configuring Amaya 11.4.4 with system raptor

From: Jack Ostroff <ostroffjh@sbcglobal.net>
Date: Sat, 17 Nov 2012 18:01:29 -0500
To: www-amaya@w3.org
Cc: Laurent Carcone <laurent@w3.org>
Message-Id: <1353193289.17630.1@ffortso4>
Now I'm really confused.  I had tried several options and edits to the  
Gentoo ebuild file, just getting different errors.  I then manually ran  
../configure, using various options, and getting a variety of different  
errors.  In the meantime, I uninstalled my previous version of Amaya,  
since it wouldn't work since I upgraded my system raptor to version 2.   
I also uninstalled my system libwww.  At that point, I happened to try  
the system install (emerge) again, and it worked fine.  I can't imagine  
what difference the uninstalls would make (although I'm not absolutely  
certain that the new install was trying to use its included libwww and  
not the system version), and I can't think of anything else I changed  
(other than the libz downgrade) that should make any difference.

However - I will now try to upgrade libz and see if Amaya continues to  
work, as mentioned in one of the links Laurent provided.

I guess the bottom line is don't believe any install error the first  
time or two - clean things out and try again from scratch, just to be  
sure.

Jack

On 2012.11.17 13:05, Jack wrote:
> [re-sent from subscribed address]
> 
> I was running zlib 1.2.7.  I downgraded to 1.2.5.1 (1.2.6 is marked  
> unstable on Gentoo) and it appears to get past that point, and I now  
> get a different error when creating ../bin/amaya_bin:
> 
> query.o: In function `QueryInit()':
> query.c:(.text+0x2c0a): undefined reference to `HTUnSetSocketBufSize'
> query.c:(.text+0x2df0): undefined reference to `HTSetSocketBufSize'
> collect2: ld returned 1 exit status
> 
> Those are both defined in .../libwww/Library/src/HTTCP.h and present  
> in HTTCP.o, which is included in libwwwcore.a, which is included in  
> the g++ line creating amaya_bin (-lwwwcore and -L/[trimmed full path  
> to]/Amaya/LINUX-ELF/libwww/Library/src/.libs) so I'm not sure why it  
> is not finding them.
> 
> Jack
> 
> On 2012.11.14 15:48, Laurent Carcone wrote:
>> I made a quick google research, it seems to be a problem with the  
>> zlib library [1], [2], [3].
>> Which version are you running ?
>> 
>> Laurent
>> 
>> 
>> [1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=661906
>> [2] http://forum.simutrans.com/index.php?topic=9575.0
>> [3] http://comments.gmane.org/gmane.linux.lfs.devel/11698
>> 
>> Le 14/11/12 20:28, Jack a écrit :
>>> Laurent,
>>> 
>>> Thanks for the suggestion.  However, using --disable-annot, I get
>>> 
>>> ../../amaya/html2thot.c: In function 'void GetNextHTMLbuffer(FILE*,  
>>> ThotBool*, char**, int*)':
>>> ../../amaya/html2thot.c:4353:70: error: cannot convert 'FILE*' to  
>>> 'gzFile_s*' for argument '1' to 'int gzread(gzFile_s*, void*,  
>>> unsigned int)'
>>> make[1]: *** [html2thot.o] Error 1
>>> make[1]: Leaving directory `[full-path-to]/Amaya/LINUX-ELF/amaya'
>>> make: *** [amaya_prog] Error 2
>>> 
>>> I haven't done much troubleshooting of this yet, but I don't find  
>>> anything obvious in a quick Google.
>>> 
>>> Also, while Annotations are not particularly important to me, I  
>>> also plan to try to figure out why it was failing when using the  
>>> included raptor.
>>> 
>>> Thanks for any hints or suggestions.
>>> 
>>> Jack
>>> 
>>> On 2012.11.14 05:09, Laurent Carcone wrote:
>>>> Hello,
>>>> 
>>>> If I remember correctly, raptor is used by the experimental  
>>>> Annotations service. If you don't want to use this service you can  
>>>> disable it when you launch the configure command: ../configure  
>>>> --disable-annot
>>>> 
>>>> Thanks,
>>>> Laurent
>>>> 
>>>> Le 08/11/2012 20:03, Jack a écrit :
>>>>> I am trying to compile Amaya 11.4.4 on Gentoo Linux, and have run  
>>>>> into a problem.  It appears that the configuration cannot find my  
>>>>> system raptor, and it subsequently fails to build with the  
>>>>> built-in raptor.  If anyone is interested, I will provide more  
>>>>> information on this fail in a separate thread.
>>>>> 
>>>>> I have raptor 2.0.8 installed and it appears that as of raptor  
>>>>> 2.0, raptor-config was dropped in favor of pkg-config.  I don't  
>>>>> know if Amaya would work with raptor2 but if  so, it needs to  
>>>>> check for pkg-config raptor2 instead of raptor-config.  If  
>>>>> raptor2 will work, I would much rather see a fix so it is  
>>>>> possible.  If the code is still based on raptor1, then I'll  
>>>>> pursue why the internal raptor is not working.
>>>>> 
>>>>> Thanks for any suggsetions.
>>>>> 
>>>>> Jack
>>>>> 
>>>>> 
>>>> 
>>> 
>>> 
>> 
> 
Received on Saturday, 17 November 2012 23:02:49 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 14:53:43 UTC