W3C home > Mailing lists > Public > www-amaya@w3.org > April to June 2006

Re: Amaya 8.8.51 Bug: Inserting an image in <DD> does not always work.

From: Martin Duerst <duerst@it.aoyama.ac.jp>
Date: Fri, 26 May 2006 16:35:40 +0900
Message-Id: <6.0.0.20.2.20060526163021.02365570@localhost>
To: Laurent Carcone <carcone@w3.org>, Thomas Jedenfelt <thomas_jedenfelt_1@operamail.com>
Cc: www-amaya@w3.org

Hello Laurent,

I have observed some behavior/bug similar to the one described by Thomas.
If I try to create a <code> element e.g. at the start of an empty <p>,
I get told "Invalid Selection". But the Amaya version is 9.5 (April 12 2006).

I discovered the workaround of entering a character myself.
But I still consider it a bug. From your mail below, I'm
not completely sure that you also consider it a bug. Do you?

Regards,   Martin.

At 18:50 06/05/25, Laurent Carcone wrote:
 >
 >Hello Thomas,
 >
 >Thomas Jedenfelt wrote:
 >
 >>Amaya 8.8.51
 >>Windows XP
 >>
 >>When inserting an image within a Definition Detail (<dd>), the image 
dialogue box will not always appear.
 >>(It concerns inserting both by way of the keyboard shortcut (Ctrl+h+i) 
and the Menu.)
 >>
 >>Steps to reproduce:
 >>
 >>  1. Create a new document.
 >>  2. Insert a Definition List (DL).
 >>  3. Enter a text string for DT.
 >>  4. Insert a DD, and then try to insert an image.
 >>
 >>
 >Indeed, it happens when we try to insert an image immediately after 
having created the <dd>.
 >The following structure (block \ dd \ dl \ body \ html) is displayed in 
the status bar when a <dd> is created, I guess Amaya creates a temporary 
element <block> replaced by a element <Text> as soon as a character is 
typed, and that element <block> doesn't accept an element <img>.
 >
 >>A work-around is to Reload the document. Then the image dialogue box 
will appear.
 >>
 >>
 >Another work-around is to enter and remove a character in the <dd> before 
to insert an image.
 >
 >>Regards,
 >>Thomas Jedenfelt
 >>
 >>
 >Thanks for the report.
 >
 >Laurent Carcone
 >
 >>P.S.
 >>Thanks for fixing the "white-space" issue in the new version (8.8.51).
 >>
 >>
 >
 >
 > 
Received on Sunday, 28 May 2006 00:36:54 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 14:53:36 UTC