W3C home > Mailing lists > Public > www-amaya@w3.org > January to March 2005

Amaya 9.1, windows - problems with non so-8859-2 characters entry

From: Jakub Holý <j.holy@sh.cvut.cz>
Date: Mon, 14 Mar 2005 22:13:51 +0100
Message-ID: <4235FE8F.30109@sh.cvut.cz>
To: www-amaya@w3.org

Hi,
  I've done some tests under Windows 2000, Czech localization, and the
results are:
1. In the URL bar I can type any letter from latin2, at least those that
I tried;
2. In the document I cannot type some letter such as t+caron and z+caron
but e.g. r+caron is ok - that's strange because a) the behaviour differs
under Windows and Linux and b) there're 2 groups of accented characters
in Czech with respect to possible problems: the 1st one is less
troublesome and sometimes is ok even if the other is not (e.g. e+caron)
and the 2nd one that usually makes problems (e.g. r+caron, t+caron) -
normally the whole group doesn't work (=> no accented characters at all
or only those in the 1st group or all of them are ok) - but here we've 2
characters from the 2nd group (r+caron, t+caron) of which one can be
typed and the other cannot. That's strange.
3.The source view shows the characters, not entities; sorry for the
mistaken info.

------------------------
I. Tests under Linux
I've tried Amaya 9.1 from Feb 24 with my Debian Linux and the input of
accented character is OK except for the aforementioned 't' with caron.
Moreover, 's' with caron - no matter how I try to type it - behaves as a
hot key and turns the display of the left-side panel 'Outils' (Tools in
English?) on/off; I've tried to switch to the Czech keyboard and type it
(it's located on the same key as number 3 on US keyboard), to switch to
the Czech keyboard only temporarily (right-Alt + 3) and to type it as a
composed character (first the caron, then the normal 's') - but no
difference. If caps lock is on it toggles the full-screen mode instead.

The 't' with caron doesn't have a key on its own so I have to type it as
a composed character: 'caron' + 't', caron is located on the same key as
'+' on a US keyboard (not the one on the num-pad, but the one 2 places
left to backspace). Maybe it's similar to s+caron and is mapped to a
function that has no evident outcome?

IMPORTANT: 1) I've realized that the t+caron cannot be typed in the URL
panel (only 't' appears there; on the contrary, when typed in the
document, nothing appears) while the s+caron can.
2) All the characters are displayed correctly both in the document and
the source code view once inserted.

> How can I reproduce the senario?
Run Amaya, open a new document, switch to the Czech keyboard, press
Shift++ (caron) followed by 't' for t+caron or press 3 for s+caron.



Irene Vatton a écrit :
> Le Dimanche 06 Mars 2005 10:17, Jakub Holý a écrit :
> 
>>Once again, some iso-8859-2 characters cannot be typed in the editing view.
>>The character t with caron described below cannot be typed in a document
>>- neither in the main view nor in the source code view - though it may
>>be typed in the url field. 
> 
> 
> How do you insert this character? With a contol sequence or just a keyboard 
> key?
> How can I reproduce the senario?
> 
> 
>>If I copy and insert it from another
>>application it's displayed correctly. When I look in the source after that,
>>it doesn't display the character but its code.
>>&#357; ť  Latin Small Letter T With Caron; unicode code: 0165
> 
> 
> If the character is not available in current encoding, Amaya generates an 
> entity that gives the unicode value.
> If it displays &#357; instead of &#165; it probably receives a wrong character 
> (the character 357 doesn't exist). it seems a confusion with the local 
> encoding.
> 
> 
>>Platform info
>>Amaya 9.1
>>OS: Windows 2000
> 
> 
> How do you insert the 

-- 
e-mail: jakub.holy@centrum.cz
www:    http://jakubholy.webpark.cz/index.html
ICQ:    98180462
Received on Monday, 14 March 2005 21:04:44 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 1 April 2014 11:01:43 UTC