W3C home > Mailing lists > Public > www-amaya@w3.org > April to June 2005

Re: amaya bug?

From: Laurent Carcone <laurent.carcone@wanadoo.fr>
Date: Tue, 19 Apr 2005 10:28:15 +0200
Message-ID: <4264C11F.40100@wanadoo.fr>
To: Joseph Reagle <reagle@mit.edu>
Cc: www-amaya@w3.org

Hello Joseph,

Thanks for the trace,
I don't know if it's an Amaya bug. I found  some reports with the same 
codes and it seems to be related to xorg
( http://ubuntuforums.org/archive/index.php/t-23281.html
http://forums.gentoo.org/viewtopic.php?t=220778&highlight=flash)
I found also these codes for a GDK_PixBuf problem.
We'll investigate in the Amaya side, but we don't use ubuntu and xorg. 
Does anybody else got the same error ?

Regards,
Laurent Carcone

Joseph Reagle wrote:

>strace is attached.
>
>  
>
>>Recently upgraded to Ubuntu Hoary which runs xorg. Amaya worked earlier 
>>today, but is now giving me this message on (wx-9.1-1) and also complains 
>>with similar message on the 8.7.2 too.
>>
>>urd:/home/reagle> amaya
>>The program 'amaya' received an X Window System error.
>>This probably reflects a bug in the program.
>>The error was 'BadMatch (invalid parameter attributes)'.
>>  (Details: serial 262 error_code 8 request_code 147 minor_code 3)
>>  (Note to programmers: normally, X errors are reported asynchronously;
>>   that is, you will receive the error a while after causing it.
>>   To debug your program, run it with the --sync command line
>>   option to change this behavior. You can then get a meaningful
>>   backtrace from your debugger if you break on the gdk_x_error() 
>>    
>>
>function.)
>  
>
Received on Tuesday, 19 April 2005 08:28:20 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 14:53:33 UTC