W3C home > Mailing lists > Public > www-amaya@w3.org > July to September 2003

Re: Bug: Color change joins previously colored <pre> lines

From: Laurent Carcone <Laurent.Carcone@inrialpes.fr>
Date: Thu, 28 Aug 2003 12:24:41 +0200
To: jlanus@netscape.net
Cc: www-amaya@w3.org
Message-Id: <20030828102441.99C28170FE@tux.inrialpes.fr>

> 
> On Sun, 24 Aug 2003 16:42:37 -0300
> Juan Lanus <jlanus@netscape.net> wrote:
> 
> > 
> > Hi, Amaya.
> > 
> > This is a bug report in the UI.
> > The steps to reproduce it are the following:
> > 
> > 1- create new document
> > 2- create a <pre> tag
> > 3- paste some text, several lines
> > 4- select all text and change color with Style => Colors
> > 5- make a single selection including some characters of the
> >     end of a line and some characters at the beginning of the
> >     following line
> > 6- change color of the selection using Style => Colors
> > 
> > Color change operates right, but the second line is appended to the 
> > previous one
> > The outcome is two tags, one with the ending chars of the first line and 
> > the other with the starting chars of the second line. The end-of-line 
> > between those two parts is lost.
> > 
> > Saludos!
> > --
> > Juan Lanus
> > TECNOSOL
> > Argentina
> 

Hello Juan,

Thanks for the precise report.
This problem is now fixed in the CVS base and will be released shortly.

Thanks

Laurent Carcone
Received on Thursday, 28 August 2003 06:24:45 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 1 April 2014 11:01:40 UTC