W3C home > Mailing lists > Public > www-amaya@w3.org > July to September 2001

Re: Print crashes Amaya 5.1 on Win98

From: Will W <willw@wizzards.net>
Date: Thu, 19 Jul 2001 08:11:39 -0700
Message-ID: <003a01c11065$22501720$094e28d1@compaq>
To: <www-amaya@w3.org>, "Laurent Carcone" <Laurent.Carcone@inrialpes.fr>

----- Original Message -----
From: Laurent Carcone <Laurent.Carcone@inrialpes.fr>
To: <www-amaya@w3.org>
Sent: Thursday, July 19, 2001 3:50 AM
Subject: Re: Print crashes Amaya 5.1 on Win98


> > Hi, everyone. I'm new to the list and new to Amaya. It looks like it
is
> > going to become my primary writing tool. I like the interface.
> >
> > Problem:
> >
> > When I attempt to print from Amaya 5.1 on a Win98 system, I get the
> > following messages:
> >
> > Error- Source: PrintDoc (4)
> >
> > then either I get the Windows "program has performed an illegal
> > operation and will be shut down" dialog or sometimes the blue screen
of
> > death "Fatal exception has 0A has occurred at 0147:00008831..." or
Amaya
> > crashes without any notification.
> >
> > Sometimes the material is sent to the printer and prints okay. At
other
> > times only part of the material prints. Sometimes I get multiple
copies
> > and the printer spool talks of printing "page 57 of 2 pages," etc.
> >
> > I have scanned the archives back to January for every report of
printer
> > problems or crashes I could find without seeing anything like this.
Is
> > there a fix that I've missed? Is this a known problem? If it is
> > something new, is there anything I can do to help identify it
better?
> >
> > Will Woodhull
> >
>
> Hello Will,
>
> Does your printing problem occurs with some specific documents or is
it
> general?
> If it concerns certain documents only, could you send us one of them.
>
> Thanks
>
>  -----------------------------------------
> Laurent CARCONE
> W3C - INRIA Rhône-Alpes
> email: Laurent.Carcone@inrialpes.fr / laurent.carcone@w3.org
>

The problem is general and consistently repeatable with documents from
different sources. Two that would be easy to replicate: printing the
product of the "make book" command on Manual.html has repeatedly failed
when Amaya reports printing page 64 and it also leaves the spool messed
up; printing AmayaPage.html (the default home page) also fails. And this
just failed:

<?xml version="1.0" encoding="iso-8859-1"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
  <meta http-equiv="Content-Type" content="text/html;
charset=iso-8859-1" />
  <title>No title</title>
  <meta name="GENERATOR" content="amaya 5.1" />
</head>

<body>
<p>Test. Print this.</p>
</body>
</html>

It printed okay, but that instance of Amaya spontaneously vaporized,
leaving no trace of itself even in the task list.

I just realized I haven't yet tried removing an re-installing Amaya.
I'll do so later this morning and see if that helps. (rusty with this
kind of thing-- many years since I've done much configuration work!)

Will

PS-- I'm sending this to both the list and the originator. Is that the
group's preference, or would it be better to just send replies to the
list?
Received on Thursday, 19 July 2001 11:12:46 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 7 January 2015 14:53:24 UTC