W3C home > Mailing lists > Public > www-amaya@w3.org > April to June 2000

Re: img src="xx&xx" becomes "xx&xx"

From: Irene VATTON <Irene.Vatton@inrialpes.fr>
Date: Tue, 18 Apr 2000 16:17:29 +0200
Message-Id: <200004181417.QAA06503@tahiti.inrialpes.fr>
To: "A Sims" <sims@camtech.net.au>
cc: www-amaya@w3.org

Hi,

The bug was fixed for the attribute href="" but not for the src="".
It's now OK in the release 3.1.
Thanks for the report.
   Irene.

> I believe this was discussed some time ago but is still not fixed in 3.0.
> 
> In my page http://www.adelaide.net.au/~sims/jafa/index.html I have the line
> 
> <img
> src="http://www.adelaide.net.au/cgi-bin/Count23.cgi?df=sims.dat&amp;dd=B&amp
> ;cache=F&amp;expires=43200&amp;frgb=0bffff"
> 
> but after editing with Amaya it becomes
> 
> <img
> src="http://www.adelaide.net.au/cgi-bin/Count23.cgi?df=sims.dat&dd=B&cache=F
> &expires=43200&frgb=0bffff"
> 
> I need the &amp; to remain intact to pass the validator test at
> http://validator.w3.org/ so that the URI conforms to section 5.3.2 of the
> HTML 4.0 recommendation:
> 
> "Authors should use "&amp;" (ASCII decimal 38) instead of "&" to avoid
> confusion with the beginning of a character reference (entity reference open
> delimiter). Authors should also use "&amp;" in attribute values since
> character references are allowed within CDATA attribute values."
> 
> Sims
> 
> 
> 

-- 
     Irene.
Received on Tuesday, 18 April 2000 10:18:17 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 1 April 2014 11:01:34 UTC