W3C home > Mailing lists > Public > www-amaya@w3.org > July to September 1999

Re: interrupting current transfer

From: <jose.kahan@imag.fr>
Date: Mon, 6 Sep 1999 19:45:30 +0200 (MET DST)
Message-Id: <199909061745.TAA25429@tuvalu.inrialpes.fr>
To: VE3LL@RAC.CA (John Russell)
Cc: www-amaya@w3.org
Hello John,

In our previous episode, John Russell said:
> 
> my environment is windows 95 / amaya 2
> internet connect through network ( cable modem )
> 
> on monday sep 6 our isp went down and service lights on modem off
> 
> but when i tried this with amaya  -- there was no way of breaking out
> all i got was the hourglass and no ability to pull down any menus
> even help  or even to size the window.........

 
> and of course no stopsign to click on even if the clicks worked
> I SEE TWO PROBLEMS HERE ... no multi-tasking  and no abort
> download option.

Amaya has a Stop button feature. However, when trying to resolve a
name (e.g., for converting www.w3.org to an IP address), we have
to make a blocking system call. There's no way to get back the hand
until that system call returns. I think that this is what happened to you.
This is a known problem, not related to Amaya, and also exists under Unix.

For all the other network tasks, we have an network-based event loop
(only does something when there's some activity), and which allows for
non-blocking network requests.

There's a new GNU project for having a non-blocking name resolver call.
It's still on an early stage (ver. 0.01), but it looks promising and it'll
solve this problem. 

Cheers,

-Jose
Received on Monday, 6 September 1999 13:45:37 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 1 April 2014 11:01:33 UTC