W3C home > Mailing lists > Public > www-amaya@w3.org > July to September 1999

Re: 2.1 on Solaris 2.5.1

From: <Irene.Vatton@inrialpes.fr>
Date: Thu, 01 Jul 1999 16:36:26 +0200
Message-Id: <199907011436.QAA20753@tahiti.inrialpes.fr>
To: Hugh Sasse <hgs@dmu.ac.uk>
cc: Amaya Mailing List <www-amaya@w3.org>
In-reply-to: Your message of Thu, 01 Jul 1999 11:08:07 +0100."
             <Pine.GSU.4.10.9907011028150.5046-100000@helios.dmu.ac.uk> 
> I have built Amaya 2.1 on Solaris 2.5.1 with EGCS-1.1.2.
> The build was successful.  On bringing up the manual
> /home/hgs/AMAYA2/Amaya/doc/amaya/Manual.html
> I had white text on a white hackground.  My foreground color is set
> to white, background to black.   I suspect this is due to the foreground
> colour not being specified in the document:
> <head>
>   <style type="text/css">
> BODY { background-color : #FFFFFF }</style>
>   <title>Using Amaya</title>
> </head>
> 
> <body lang="en">
> etc

Yes, this is an error in our page Manual.html. When we set the background color
we have to set the foreground color too.
I'll change for next versions.

> On browsing my home page
> http://www.eng.dmu.ac.uk/~hgs/
> Amaya crashes with 
> *** Thot: Irrecoverable error ***

I have a solaris box too but I have no problem with that URL.
Could you start Amaya on a debuger just to let us know where it crashs).

> The first time it did that I checked with the validator
> http://validator.w3.org/
> and I had a typo <ATRONG>...</STRONG> instead of <STRONG>...</STRONG>.
> The response still seemed a little severe.  I have corrected this, the
> page validates OK now, but Amaya still crashes.  I wonder if there
> is a cache holding the old page?  Looking at that manual page with
> Netscape, I cannot see anything on command line options to flush
> any such cache, or to increase diagnostic output.

Yes there is a cache that you can purge (see the menu Special).

> The coloured popup legends on the button bar seem a bit bigger (thanks)
> but they are still cream on yellow, and I cannot see anything to set
> the font size or colour for those.

Tooltips use the foreground color, but you cannot change the yellow
color. That is a bug.

> 
> The colour "palette" doesn't seem to have an "apply" button, only 
> a "done" button, unlike the Character Style and Format menu items.
> There seems therefore to be no way to override the colours imposed
> by the document.

Right, we still plan to add it.

  Irene.
Received on Thursday, 1 July 1999 10:36:32 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 1 April 2014 11:01:32 UTC