W3C home > Mailing lists > Public > www-amaya-dev@w3.org > April 2009

Re: compile and other troubles on Ubuntu 9.04 (latest)

From: Irene Vatton <Irene.Vatton@inria.fr>
Date: Thu, 30 Apr 2009 12:49:10 +0200
To: Jean-Marc Vanel <jeanmarc.vanel@gmail.com>
Cc: www-amaya-dev@w3.org
Message-Id: <1241088550.7223.69.camel@vanuatu.inrialpes.fr>
Le mercredi 29 avril 2009 à 19:59 +0200, Jean-Marc Vanel a écrit :
> Since I'm on x86_64 architecture and Unbuntu 9.04 there is no package
> for Amaya .
> 
> So I launched myself in this difficult adventure of compiling .
> I write difficult adventure, because I use other complex C software (
> SWI-Prolog ) that compiles out-of-the-box.
> 
> First trouble : Amaya doesn't compile.
> -----------------------------------------------------
> I did
> .../configure --with-gl
> 
> (maybe I should have done
> .../configure
> )
> 

The package is not provided because with I had access problems with that
platform too. I'll try to generate a snapshot next week.

Meanwhile you can try to compile from the following tar source:

 http://wam.inrialpes.fr/software/amaya/amaya-fullsrc-11.2-64bits.tgz

You need to install libtool, libwww-dev, libraptor1-dev and configure
with following options:

 ../configure --enable-system-libwww --enable-system-raptor

I suggest you add your install path as the current prefix and use "wx"
instead of "WX_build" for the build sub-directory:

 --prefix=/home/jmv/src/amaya-fullsrc-11.2-pre2

-- 
Irene Vatton <Irene.Vatton@inria.fr>
INRIA
Received on Thursday, 30 April 2009 10:49:51 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:49:06 GMT