W3C home > Mailing lists > Public > www-amaya-dev@w3.org > April 2009

compile and other troubles on Ubuntu 9.04 (latest)

From: Jean-Marc Vanel <jeanmarc.vanel@gmail.com>
Date: Wed, 29 Apr 2009 19:59:11 +0200
Message-ID: <e0320dfa0904291059o6cdf03afp3489ec51066c0e93@mail.gmail.com>
To: www-amaya-dev@w3.org
Since I'm on x86_64 architecture and Unbuntu 9.04 there is no package
for Amaya .

So I launched myself in this difficult adventure of compiling .
I write difficult adventure, because I use other complex C software (
SWI-Prolog ) that compiles out-of-the-box.

First trouble : Amaya doesn't compile.
-----------------------------------------------------
I did
../configure --with-gl

(maybe I should have done
../configure
)

The symptom:

make[3]: entrant dans le répertoire «
/home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/thotlib »
make[3]: quittant le répertoire «
/home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/thotlib »
g++  -o ../bin/grm ../thotlib/base/compilmsg.o parser.o grammar.o
-L../thotlib/ -lThotKernel -lz -ldl
-L/home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/wxWidgets_RELEASE/lib
-pthread   /home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/wxWidgets_RELEASE/lib/libwx_gtk2u_aui-2.8.a
/home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/wxWidgets_RELEASE/lib/libwx_gtk2u_xrc-2.8.a
/home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/wxWidgets_RELEASE/lib/libwx_gtk2u_adv-2.8.a
/home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/wxWidgets_RELEASE/lib/libwx_gtk2u_core-2.8.a
/home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/wxWidgets_RELEASE/lib/libwx_baseu_xml-2.8.a
/home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/wxWidgets_RELEASE/lib/libwx_baseu_net-2.8.a
/home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/wxWidgets_RELEASE/lib/libwx_gtk2u_gl-2.8.a
/home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/wxWidgets_RELEASE/lib/libwx_baseu-2.8.a
-pthread-lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangoft2-1.0
-lgdk_pixbuf-2.0 -lgio-2.0 -lpango-1.0 -lfreetype -lfontconfig
-lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 -lXinerama
-lSM -lexpat -lGL -lGLU -lwxregexu-2.8 -lwxtiff-2.8 -lwxjpeg-2.8
-lwxpng-2.8 -lz -ldl -lm
g++: /home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/wxWidgets_RELEASE/lib/libwx_gtk2u_aui-2.8.a
: Aucun fichier ou dossier de ce type
g++: /home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/wxWidgets_RELEASE/lib/libwx_gtk2u_xrc-2.8.a
: Aucun fichier ou dossier de ce type
g++: /home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/wxWidgets_RELEASE/lib/libwx_gtk2u_adv-2.8.a
: Aucun fichier ou dossier de ce type
g++: /home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/wxWidgets_RELEASE/lib/libwx_gtk2u_core-2.8.a
: Aucun fichier ou dossier de ce type
g++: /home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/wxWidgets_RELEASE/lib/libwx_baseu_xml-2.8.a
: Aucun fichier ou dossier de ce type
g++: /home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/wxWidgets_RELEASE/lib/libwx_baseu_net-2.8.a
: Aucun fichier ou dossier de ce type
g++: /home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/wxWidgets_RELEASE/lib/libwx_gtk2u_gl-2.8.a
: Aucun fichier ou dossier de ce type
g++: /home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/wxWidgets_RELEASE/lib/libwx_baseu-2.8.a
: Aucun fichier ou dossier de ce type
make[2]: *** [../bin/grm] Erreur 1
make[2]: quittant le répertoire «
/home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/batch »
make[1]: *** [../bin/str] Erreur 2
make[1]: quittant le répertoire «
/home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/amaya »

~/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build% ls -l
/home/jmv/src/amaya-fullsrc-11.2-pre2/Amaya/WX_build/wxWidgets_RELEASE/lib/
total 1120
-rw-r--r-- 1 jmv jmv 224584 2009-04-29 18:50 libwxjpeg-2.8.a
-rw-r--r-- 1 jmv jmv 244092 2009-04-29 18:50 libwxpng-2.8.a
-rw-r--r-- 1 jmv jmv 158044 2009-04-29 18:50 libwxregexu-2.8.a
-rw-r--r-- 1 jmv jmv 492154 2009-04-29 18:50 libwxtiff-2.8.a
drwxr-xr-x 4 jmv jmv   4096 2009-04-29 18:45 wx

-------------------------------------

After finding this message :
http://lists.w3.org/Archives/Public/www-amaya-dev/2008Mar/0001.html

I did that:

cd wxWidgets_RELEASE/
make
cd ..
make all

And I got bin/amaya_bin that runs !!!!!!!!!!!!

But .....
Second trouble : Amaya shows ugly characters
-----------------------------------------------------------------
About 1 word out of 3 is unreadable.
That is the same trouble as with the last available .deb from the Amaya site:
11.0-1 .

However the Amaya provided with Ubuntu 8 was fine, but they stopped
providing Amaya .
What is the problem between Amaya and Ubuntu ?

Thanks for your help.
-- 
Jean-Marc Vanel
Consulting, services, training,
Rule-based programming, Semantic Web
http://jmvanel.free.fr/
Received on Wednesday, 29 April 2009 17:59:53 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 7 December 2009 10:49:06 GMT