W3C home > Mailing lists > Public > www-amaya-dev@w3.org > January 2000

Re: Install problems on Solaris 2.5.1

From: <Irene.Vatton@inrialpes.fr>
Date: Fri, 07 Jan 2000 14:36:11 +0100
Message-Id: <200001071336.OAA03374@tahiti.inrialpes.fr>
To: Hugh Sasse Staff Elec Eng <hgs@dmu.ac.uk>
cc: www-amaya-dev@w3.org

Hi,

Our source tar file amaya-src-2.4.tgz includes all the Amaya and libwww stuff.
When the source tar file is unpacked it should create an Amaya directory
and a liwww directory.
I don't know why the unpack failed when it tried to create the libwww 
directory.

In-reply-to: Your message of Fri, 07 Jan 2000 12:02:47 +0000."
             <Pine.GSO.4.21.0001071142560.22959-100000@atlanta> 

> Sun Sparc Solaris 2.5.1 gcc-2.95.2
> 
> The build for amaya 2.4 seemed to go fairly* OK.
> On installing:
> gmake[2]: Entering directory `/home/hgs/Amaya/Amaya/Solaris-2.5.1/libjpeg'
> gmake[2]: Nothing to be done for `all'.
> gmake[2]: Leaving directory `/home/hgs/Amaya/Amaya/Solaris-2.5.1/libjpeg'
> ../install-sh -c -m 755 ../bin/amaya /usr/local/Amaya/applis/bin
> gmake[1]: ../install-sh: Command not found
> gmake[1]: *** [install] Error 127
> gmake[1]: Leaving directory `/home/hgs/Amaya/Amaya/Solaris-2.5.1/amaya'
> brains# pwd
> /home/hgs/Amaya/Amaya/Solaris-2.5.1
> 
> I thought configure had found an install program already.
> 
> * The only problems with the build were:
> 
> When the source tar file was unpacked it created an Amaya directory
> and put the stuff in it, but it tried to put things into a libwww
> directory which was in the same directory as the Amaya directory -- i.e
> Amaya/.. and it failed because there was no such directory.
> 
> Most software distributed as tar files creates one directory and puts
> everything below that. 
> 
> When I moved everything down one level putting the tar file in a
> new Amaya directory, creating an empty libwww directory in there with
> it, then the untarring went OK.
> 
> I didn't epect gmake to complain about the lack of an Options file, or
> a .depends file, but it created these so persumably they are OK.
> 
> 	Hugh
> 	hgs@dmu.ac.uk
> 

  Irene.
Received on Friday, 7 January 2000 08:36:19 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:25:43 UTC