RE: Issue rdfms-abouteach

It is a useful syntactic convenience for folks who
write their RDF/XML instances by hand. One can
put a bunch of resources in a bag and then make
an aboutEach statement. It also IMO can help make
an RDF instance more readable with regards to
common classifications of resources. E.g.

<rdf:Bag rdf:ID="guys">
   <rdf:li rdf:resource="#Bob"/>
   <rdf:li rdf:resource="#John"/>
   <rdf:li rdf:resource="#Joe"/>
   <rdf:li rdf:resource="#Harry"/>
   <rdf:li rdf:resource="#Frank"/>
   <rdf:li rdf:resource="#Phil"/>
</rdf:Bag>

<rdf:Bag rdf:ID="gals">
   <rdf:li rdf:resource="#Mary"/>
   <rdf:li rdf:resource="#Elain"/>
   <rdf:li rdf:resource="#Jane"/>
   <rdf:li rdf:resource="#Betty"/>
   <rdf:li rdf:resource="#Elizabeth"/>
   <rdf:li rdf:resource="#Judeth"/>
</rdf:Bag>

<rdf:Description rdf:aboutEach="#guys">
   <rdf:type rdf:resource="x:Male"/>
</rdf:Description>

<rdf:Description rdf:aboutEach="#gals">
   <rdf:type rdf:resource="x:Female"/>
</rdf:Description>

This is also very useful for asserting "local"
classifications of resources for third-party
knowledge where you cannot touch the original
schemas.

I know of one standards group which is in the
process of finalizing the decision to migrate
to RDF and is planning on using aboutEach a good
deal, though I'm not at liberty (yet) to say who 
that is.

*Please* leave it alone.

Cheers,

Patrick


> -----Original Message-----
> From: ext Jeremy Carroll [mailto:jjc@hplb.hpl.hp.com]
> Sent: 15 November, 2001 17:32
> To: Dave Beckett; w3c-rdfcore-wg@w3.org
> Subject: RE: Issue rdfms-abouteach
> 
> 
> 
> DaveB:
> >
> > Issue http://www.w3.org/2000/03/rdf-tracking/#rdfms-abouteach
> >
> > Summary: I propose to remove rdf:aboutEach from the RDF/XML 
> language.
> 
> Hmmmm...
> 
> I have a certain personal investment in not doing so :), 
> having the only
> streaming mode parser that implements aboutEach correctly 
> (tempting fate).
> But Dave's arguments hang together. I am hoping somebody from 
> the document
> author side will make a good case for retaining it; 
> personally, I can't.
> 
> 
> What I believe the previous WG were trying to do was to allow 
> provenance
> information to be included in RDF, using pairs of rdf:bagID and
> rdf:aboutEach. I think this failed.
> Probably we should be having experiments, outside of a 
> standard RDF, in how
> best to handle provenance. I suspect a more document centric and less
> resource centric approach would be better.
> 
> 
> 
> [[[[
>      "For very large files (more than 100 Megabyte?), the way ARP
>        handles rdf:aboutEach may exhaust memory. I have the design of
>        a fix, but it is not high on my ToDo list. e-mail me if you
>        wish to move it up."
>     -- Jeremy, http://www.hpl.hp.co.uk/people/jjc/arp/issues.html
> ]]]]
> 
> No-one has taken me up on this!
> 
> 
> Jeremy
> 
> 
> 
> 

Received on Friday, 16 November 2001 05:51:02 UTC