W3C home > Mailing lists > Public > w3c-rdfcore-wg@w3.org > August 2001

Re: test case file names

From: Art Barstow <barstow@w3.org>
Date: Fri, 17 Aug 2001 17:32:00 -0400
To: w3c-rdfcore-wg@w3.org
Message-ID: <20010817173159.A3152@w3.org>
[Not sure what went wrong, but her'e a second attempt ...]

Sorry to pollute the list with a banal topic but while
thinking about what needs to be documented wrt the WG's
test cases in:

 http://www.w3.org/2000/10/rdf-tests/rdfcore/

it seems like a consistent file naming convention would be
useful.

Anyhow, below are some related questions and comments.

Art
---

1. Would the person(s) that created the following test cases:
 
 ./rdfms-abouteach/test1.rdf
 ./rdfms-aboutEach-on-object/test1.rdf
 ./rdfms-nested-bagIDs/test1.rdf
 ./rdfms-propElt-id-with-dr/test1.rdf

please tell me if these are legitimate test cases or not?  That is, 
were they created soley as a way to test writing on the W3C's site 
or are they good tests?  If they are good tests then would whomever 
created the test cases, please create a corresponding N-Triples file?

2. The most common practice is to name files that contain illegal RDF:

  error<nnnn>.nrdf

where <nnnn> is a sequence number and I believe the "nrdf" means 
"not RDF".  Since the file naming convention should probably be
documented [for the public], I'm wondering if we want to stick
with this convention.  It seems kind'a redundant to name them both 
error and nrdf and that simply error<nnnn>.rdf would be sufficient
to convey that the file is illegal RDF.

3. The following files:

 ./rdfms-difference-between-ID-and-about/test1.nt
 ./rdfms-difference-between-ID-and-about/test1.rdf
 ./rdfms-difference-between-ID-and-about/test2.nt
 ./rdfms-difference-between-ID-and-about/test2.rdf

do not follow the commonly used file naming convention of:

 test<nnnn>.rdf

Although I don't recall any discussion of "the" file naming
convention, I think it would be good to be consistent thus
I would recommend that the following files be renamed to
test000{1,2}.{nt,rdf}.

Likewise, to be consistent with other error files the following 
file:

 ./rdfms-difference-between-ID-and-about/error1.rdf

should be renamed to error0001.rdf or error000.nrdf depending
on what folks think about #2 above.

4. I like the way Aaron created an "Overview.html" file in:

 http://www.w3.org/2000/10/rdf-tests/rdfcore/rdfms-difference-between-ID-and-about/

Although I don't a README-type file should be required, it is a 
nice touch.

BTW Aaron, can this file be obsoleted:

 ./rdfms-difference-between-ID-and-about/index.html
Received on Friday, 17 August 2001 17:32:00 EDT

This archive was generated by hypermail pre-2.1.9 : Wednesday, 3 September 2003 09:38:47 EDT