W3C home > Mailing lists > Public > w3c-dist-auth@w3.org > July to September 2005

.htaccess protected webdav folder inaccessible from windows only

From: Daniel Klein <bringa@gmail.com>
Date: Thu, 4 Aug 2005 14:58:06 +0200
Message-ID: <ba28b0400508040558542ff267@mail.gmail.com>
To: w3c-dist-auth@w3.org

Hi,

first of all: I've searched for a general webdav discussion mailing
list. This is the best I've come up with. After looking through the
archives, I'm not sure if this is the proper place to ask webdav
related questions--thus, if I'm intruding and in the wrong place
altogether, please do let me know (and I'd be obliged if you could
point me in the right direction)

My problem is this: have a webdav activated folder (using mod_dav for
apache 1.3.33) on my webserver. As long as I do not try to protect it,
everything works fine: I can add it as a network resource in windows,
I can access it from inside word, and if I do a "net use g: <url>" in
my commandline, it is properly accepted as a new drive.

Now I placed a .htaccess file in the web_dav folder; the contents are
as simple as they can be:

AuthType Basic
AuthName webdav
AuthUserFile /home/dante/web_docs/dav_test/.htpasswd
require valid-user

The .htpasswd file has also been created and assigned proper rights.
Accessing this folder with my webbrowser of choice causes a prompt for
password, and upon entering the right password, I can see the content
just fine.

So I tried the same thing as before on windows; no dice. It would keep
asking me for the password, no matter how often and how carefully I
typed it. This was the same for net use and for creating a new network
resource.

My next test was to install Cadaver on a DIFFERENT linux server; I
used it to connect to my webdav folder, entered username and password
and got in just fine. Up and downloading worked perfectly.

For a moment I was afraid windows might have issues with the crypted
passwords (ridiculous as that sounds), so I changed the passwords in
.htpasswd to clear text, but of course that didn't help either.

So that's my situation: I can open the folder for viewing from Windows
just fine; I can open it as a fully functional webdav folder from
another LINUX box; logging in from Windows doesn't seem to work at
all.

I googled extensively for this (what's up with all the Chinese webdav
pages? ;P); I couldn't find anything.

Any help would be greatly appreciated!

Daniel Klein
Received on Thursday, 4 August 2005 12:58:14 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 2 June 2009 18:44:09 GMT