W3C home > Mailing lists > Public > w3c-dist-auth@w3.org > October to December 1999

Re: webfolders.mydocsonline.com server

From: Greg Stein <gstein@lyra.org>
Date: Sat, 11 Dec 1999 06:28:28 -0800 (PST)
To: Joe Orton <joe@orton.demon.co.uk>
cc: feedback@mydocsonline.com, w3c-dist-auth@w3.org
Message-ID: <Pine.LNX.4.10.9912110624070.16305-100000@nebula.lyra.org>
On Sat, 11 Dec 1999, Joe Orton wrote:
> The PROPFIND response on this server is broken. I send:
>...
> Response body is:
> 
> <?xml version="1.0" encoding="utf-8"?>
> <D:multistatus xmlns:D="DAV:">
> <D:response xmlns:i0="DAV:">
> <D:href>/</D:href>
> <D:propstat>
> <D:prop>
> <D:getlastmodified>Oct,  Jan   GMT</D:getlastmodified>
> <D:resourcetype><D:collection/></D:resourcetype>
> </D:prop>
> <D:status>HTTP/1.1 200 OK</D:status>
> </D:propstat>
> <D:propstat>
> <D:prop>
> <i0:getcontentlength/>
> </D:prop>
> <D:status>HTTP/1.1 404 Not Found</D:status>
> </D:propstat>
> </D:response>
> </D:multistatus>
> 
> Where the DAV:getlastmodified element is corrupt.

The MyDocsOnline server is mod_dav (modified, I believe) under the covers.
Looking at the code for getlastmodified, it would seem there is a problem
with the C lib on the server. I'm doing the following:

    sprintf(buf,
	    "%s, %.2d %s %d %.2d:%.2d:%.2d GMT",

I can't see how it would generate the text you saw... very weird. I don't
have a developer contact there, so let's hope they're listening here or
will respond soon with the feedback@ address (so I can help them with the
problem).

Thanx for reporting this, Joe!

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/
Received on Saturday, 11 December 1999 09:27:03 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 2 June 2009 18:43:52 GMT