RE: Style question

> -----Original Message-----
> From: semantic-web-request@w3.org [mailto:semantic-web-request@w3.org] On
> Behalf Of ben syverson
> Sent: Sunday, March 06, 2005 4:28 PM
> To: semantic-web@w3.org
> Subject: Re: Style question
> 
> 
> 
> On Mar 6, 2005, at 7:41 AM, Geoff Chappell wrote:
> 
> [...]
> > i.e. becca is a person with green eyes. The value of eyeColor for any
> > person
> > must be one of the defined EyeColors (green or brown).
> 
> Actually, I was shooting simply for: Becca is a person with green and
> brown eyes (brown in the center, green at the edges, specifically, but
> lets assume the user doesn't want to get that specific).

In that case, maybe you just want to say something like this:

<?xml version="1.0"?>
<rdf:RDF xmlns:ex="http://likn.org/#"
   xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
   xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
   xmlns:owl="http://www.w3.org/2002/07/owl#">
	<ex:person rdf:about="http://likn.org/#becca">
		<ex:eyeColor rdf:resource="http://likn.org/#green"/>
		<ex:eyeColor rdf:resource="http://likn.org/#brown"/>
</ex:person>
</rdf:RDF>

I'd personally stay away from bags - they don't really carry much meaning.
For example, you can't infer that a relation between a resource and a bag
holds between the resource and the members of the bag.

> But this raises an interesting question: I'd like to keep the ontology
> in a separate file, so that if a constraint on "person" is updated, I
> don't have to update every person RDF. Is that outsourcing too much
> information from the main files people will be looking at (the RDFs)?

It often makes sense to have class and instance data separate. If you do,
it's probably a good idea to either make the schema retrievable at its uri
or point to it via owl:imports or rdfs:seeAlso in the instance data.
 
> Also, what do I do with a line like:
> <likn:instanceOf rdf:resource="http://likn.org/#person" />
> Is there a way to define through OWL that anything that is a
> likn:instanceOf is also an owl instance of the target resource's class?

You could make likn:instanceOf a rdfs:subProperty of rdf:type. But why not
just use rdf:type? Is likn:instanceOf really a specialization of rdf:type in
any way or is it just another name for the same thing?


> And how would I tie the two files together? Or should I be doing this
> differently? The ontology should be general enough that individuals
> such as "Becca" don't show up in the ontology file unless they have
> specific restraints...
> 
> I'm concerned that rdf:type by itself is too vague. For example:
> <dc:title>Music Box Theater</dc:title>
> <rdf:type rdf:resource="http://likn.org/#theater" />
> Does this imply that the Music Box is a type of theater, when in fact
> it's an instance of Theater?

It says that the resource is an instance of theater. It does not say that it
is a subclass of theater (which I think is what you mean by "is a type of
theater") - for that you'd say:
	
	<rdfs:subClassOf rdf:resource="http://likn.org/#theater" />
 
> - ben

Geoff

Received on Sunday, 6 March 2005 22:11:32 UTC