W3C home > Mailing lists > Public > public-xml-testsuite@w3.org > April 2004

Fwd: Error in test case entry sun/not-wf/encoding07.xml

From: Sandra Martinez <sandra.martinez@nist.gov>
Date: Thu, 29 Apr 2004 08:24:43 -0400
Message-Id: <5.0.0.25.2.20040429081807.01f4dc20@mailserver.nist.gov>
To: public-xml-testsuite@frink.w3.org

Should I add all these comments to the current XML TS issues table, which 
is title "XML 1.2 2nd edition Test Suite Issues"? My recommendation is to 
change the title to "XML Conformance Test Suite Issues" and continue adding 
to this one.

Sandra


>X-Sieve: CMU Sieve 2.2
>X-Original-To: public-xml-testsuite@listhub.w3.org
>Delivered-To: public-xml-testsuite@listhub.w3.org
>From: "Karl Waclawek" <karl@waclawek.net>
>To: <public-xml-testsuite@w3.org>
>Date: Wed, 28 Apr 2004 16:06:16 -0400
>X-Mailer: Microsoft Outlook Express 6.00.2800.1158
>X-AntiVirus: Checked for viruses by Gordano's AntiVirus Software
>X-AntiSpam: Checked for restricted content by Gordano's AntiSpam Software
>Subject: Error in test case entry sun/not-wf/encoding07.xml
>X-Archived-At: 
>http://www.w3.org/mid/000b01c42d5c$438705e0$9e539696@citkwaclaww2k
>Resent-From: public-xml-testsuite@w3.org
>X-Mailing-List: <public-xml-testsuite@w3.org> archive/latest/103
>X-Loop: public-xml-testsuite@w3.org
>Sender: public-xml-testsuite-request@w3.org
>Resent-Sender: public-xml-testsuite-request@w3.org
>List-Id: <public-xml-testsuite.w3.org>
>List-Help: <http://www.w3.org/Mail/>
>List-Unsubscribe: 
><mailto:public-xml-testsuite-request@w3.org?subject=unsubscribe>
>Resent-Date: Wed, 28 Apr 2004 16:06:44 -0400 (EDT)
>X-MailScanner:
>X-MailScanner-From: public-xml-testsuite-request@w3.org
>
>
>The XML file listing SUN's not-wf test cases seems to have an
>error in the entry for the test case with ID encoding07:
>
>The entry looks like this:
>
><TEST URI="not-wf/encoding07.xml" ID="encoding07" TYPE="not-wf" 
>SECTIONS="4.3.1 [77]"
>ENTITIES="parameter">
>     Text declarations (which optionally begin any external entity)
>     are required to have "encoding=...". </TEST>
>
>The attribute ENTITIES should have the value "general", since the test
>case requires general entity expansion, as can be seen from the test case 
>itself:
>
><!DOCTYPE root [
>     <!ELEMENT root EMPTY>
>
>     <!--
>  reusing this entity; it's got no markup decls,
>  so it's legal except for a missing "encoding=...".
>     -->
>     <!ENTITY empty SYSTEM "dtd07.dtd">
>]>
><root>&empty;</root>
>
>
>I came across this problem as our test app did not turn on
>general entity expansion and so the Expat parser would not
>report a WF error.
>
>Karl

Sandra I. Martinez
National Institute of Standards and Technology
100 Bureau Drive, Stop 8970,
Gaithersburg, Md. 20899

(301) 975-3579
sandra.martinez@nist.gov
Received on Thursday, 29 April 2004 08:25:38 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:22:04 GMT