W3C home > Mailing lists > Public > public-xml-schema-testsuite@w3.org > July 2010

[Bug 10121] New: WG-submitted substitution-group tests

From: <bugzilla@jessica.w3.org>
Date: Fri, 09 Jul 2010 13:33:19 +0000
To: public-xml-schema-testsuite@w3.org
Message-ID: <bug-10121-1590@http.www.w3.org/Bugs/Public/>
http://www.w3.org/Bugs/Public/show_bug.cgi?id=10121

           Summary: WG-submitted substitution-group tests
           Product: XML Schema Test Suite
           Version: 2006-11-06
          Platform: PC
        OS/Version: Windows NT
            Status: NEW
          Severity: normal
          Priority: P2
         Component: NIST tests
        AssignedTo: ht@inf.ed.ac.uk
        ReportedBy: mike@saxonica.com
         QAContact: public-xml-schema-testsuite@w3.org


1. There are components in the test suite that are not listed here in Bugzilla.
I have therefore been obliged to misclassify this bug against the NIST tests.

2. In snbranch.xsd, notQname should be notQName. I have taken the liberty of
correcting this in CVS.

3. Instance document snn1a is described as invalid. I can't see any reason for
this. It claims to be something to do with substitution groups, but the only
element that can substitute for another is s1, and this plays no further role
in either the schema or the instance.

4. Conversely, snn1c is described as valid, but as far as I can see, it doesn't
satisfy the content model, for reasons quite unconnected with #definedSibling.

-- 
Configure bugmail: http://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Friday, 9 July 2010 13:33:20 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Friday, 9 July 2010 13:33:21 GMT