W3C home > Mailing lists > Public > public-xml-schema-testsuite@w3.org > November 2006

False "invalid instance" results in MS regex tests

From: Michael Kay <mike@saxonica.com>
Date: Thu, 16 Nov 2006 09:54:08 -0000
To: <public-xml-schema-testsuite@w3.org>
Message-ID: <005301c70965$292f2190$6401a8c0@turtle>

The following 24 tests have an expected result of "invalid" for the instance
document where I would have expected "valid", and in fact the documentation
comment in the metadata also indicates an expected result of "valid".

I haven't checked them all individually, but they all seem to involve
questions of the Unicode character categories assigned to characters outside
the BMP.

<out xmlns:saxon="http://saxon.sf.net/">
   <test group="reG50" name="reG50.i"/>
   <test group="reJ11" name="reJ11.i"/>
   <test group="reJ13" name="reJ13.i"/>
   <test group="reJ19" name="reJ19.i"/>
   <test group="reJ21" name="reJ21.i"/>
   <test group="reJ23" name="reJ23.i"/>
   <test group="reJ25" name="reJ25.i"/>
   <test group="reJ29" name="reJ29.i"/>
   <test group="reJ31" name="reJ31.i"/>
   <test group="reJ33" name="reJ33.i"/>
   <test group="reJ35" name="reJ35.i"/>
   <test group="reJ61" name="reJ61.i"/>
   <test group="reJ69" name="reJ69.i"/>
   <test group="reJ75" name="reJ75.i"/>
   <test group="reJ77" name="reJ77.i"/>
   <test group="reL98" name="reL98.i"/>
   <test group="reL99" name="reL99.i"/>
   <test group="reM98" name="reM98.i"/>
   <test group="reN99" name="reN99.i"/>
   <test group="reS21" name="reS21.i"/>
   <test group="reS42" name="reS42.i"/>
   <test group="reT63" name="reT63.i"/>
   <test group="reT84" name="reT84.i"/>
   <test group="reDH7a" name="reDH7a.i"/>
</out>

Michael Kay
Received on Thursday, 16 November 2006 09:54:19 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:21:55 GMT