W3C home > Mailing lists > Public > public-xml-processing-model-wg@w3.org > November 2007

Re: XPath version

From: Norman Walsh <ndw@nwalsh.com>
Date: Wed, 14 Nov 2007 09:08:34 -0500
To: public-xml-processing-model-wg@w3.org
Message-ID: <m24pfosyvx.fsf@nwalsh.com>
/ Innovimax SARL <innovimax@gmail.com> was heard to say:
|> 6. In the scope of xpath-version=1.0, if the processor uses XPath 2.0,
|> it SHOULD evaluate the expression using XPath 1.0 backwards
|> compatibility mode. If it does not support that mode, it simply
|> attempts to evaluate the expression as XPath 2.0 and throws a dynamic
|> error if it doesn't work.
|
| This one worries me the most : sometime XPath 2.0 processor IS PERFECTLY
| able to evaluate the expression, but the result is wrong.

We could say that an implementation MUST support backwards compatibility,
I suppose.

Do you have some expressions in mind that you think might really turn up
in pipelines?

                                        Be seeing you,
                                          norm

-- 
Norman Walsh <ndw@nwalsh.com> | There is no excellent beauty that hath
http://nwalsh.com/            | not some strangeness in the
                              | proportion.--Sir Francis Bacon

Received on Wednesday, 14 November 2007 14:08:53 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 8 January 2008 14:21:54 GMT