Re: Cardinality of inputs & outputs

/ Jeni Tennison <jeni@jenitennison.com> was heard to say:
| I don't want to do anything too major (like saying that you don't have
| to bind to optional inputs at all). I think that doing
| cardinality="one", cardinality="zero-or-one",
| cardinality="zero-or-more" and cardinality="one-or-more" is the right
| amount of laziness here.

Like I said, I don't feel strongly about it. I wonder if we can do
better at the syntax level though. The attribute name "sequence" seems
simple and easy to explain. The attribute name "cardinality" is a bit
more technical.

I'm not coming up with anything I like better though:

  sequence = one (or no) | one-or-more | zero-or-one | zero-or-more

  sequence-length = one (or exactly-one) | at-most-one | one-or-more | unbounded

  sequence = one | optional | one-or-more | any

Bleh.

|>   <p:input port="source"><p:inline/></p:input>
|
| I think you mean:
|
|   <p:input port="source" />
|
| to bind to the empty sequence.

I don't know. I thought about that. That looks to me like a port with
no binding and therefore it wouldn't seem unreasonable for it to get
he default binding.

We could say that that's not what that means, of course.

                                        Be seeing you,
                                          norm

-- 
Norman Walsh <ndw@nwalsh.com> | Youth lasts much longer than young
http://nwalsh.com/            | people think.--Comtesse Diane

Received on Wednesday, 23 May 2007 13:41:31 UTC