W3C home > Mailing lists > Public > public-xml-processing-model-comments@w3.org > April 2008

more comments on latest xproc II

From: James Fuller <james.fuller.2007@gmail.com>
Date: Wed, 16 Apr 2008 00:27:43 +0200
Message-ID: <a0ad8ffe0804151527k70ffd69ct4bf25abafa683f77@mail.gmail.com>
To: public-xml-processing-model-comments@w3.org

------------------------------------

in section 3 Syntax Overview

'Six kinds of things are named in XProc:'

propose refining to

'There are six kinds of entities defined in XProc'

named implies that they have a @name attribute, where as 'things' is a
bit of a wholly term

------------------------------------

minor nit with p:variable

in section 2.1 Steps subpipeline is defined to take a top level p:variable

subpipeline = p:variable*,
(p:for-each|p:viewport|p:choose|p:group|p:try|p:standard-step|pfx:user-pipeline)+

furthermore p:choose and p:try can also have a top level p:variable
defined ... should we harmonize this usage of p:variable
and allow outside of nested subpipeline on p:for-each, p:viewport, and
p:group elements as well ?

------------------------------------

should we add some concept of http timeout on c:request ? perhaps as
an optional option

same thing goes for proxy

also, I did not see any discussion, but I may have missed it  .... did
the WG consider any need for an HTTP_REFERER type element in
c:response ? I would propose adding it to the c:http-response element
as an attribute.

------------------------------------

in section 7.1.15 p:namespace-rename

this step has always seemed to me slightly incorrect, e.g. the
operation that is occuring is more appropriately called
namespace-mapping ... I prefer how XSLT 2.0 approaches this using
namespace-alias function ... below is a rough translation of what this
would look like in XProc

<p:namespace-alias xmlns:old="http://someold.com/namespace"
xmlns:new="somenew.com/namespace">
	<p:option name="literalNS" value="old"/>
	<p:option name="targetNS" value="new"/>
</p:namespace-alias>

I think its pretty clear and would propose we add to steps (and remove
namespace-rename)

------------------------------------

cheers, Jim Fuller
Received on Tuesday, 15 April 2008 22:28:18 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 15 April 2008 22:28:19 GMT