W3C home > Mailing lists > Public > public-xml-core-wg@w3.org > June 2009

RE: question about xlink 1.1

From: Grosso, Paul <pgrosso@ptc.com>
Date: Tue, 16 Jun 2009 09:23:25 -0400
Message-ID: <CF83BAA719FD2C439D25CBB1C9D1D3020FF8AE74@HQ-MAIL4.ptcnet.ptc.com>
To: <public-xml-core-wg@w3.org>


> -----Original Message-----
> From: Henry S. Thompson [mailto:ht@inf.ed.ac.uk]
> Sent: Tuesday, 2009 June 16 7:57
> To: Grosso, Paul
> Cc: public-xml-core-wg@w3.org
> Subject: Re: question about xlink 1.1
> 
> Grosso, Paul writes:
> 
> >> 9.  XLink 1.1.
> >>
> >> See also http://www.w3.org/XML/Group/Core#xlink1.1
> >
> >
> >>
> >> There's an open question about whether the XSD/DTD
> >> should default the xlink:type attribute value.
> >> None of this effects our last call because the
> >> XSD/DTD are not normative.
> >>
> >> Can someone remind us what this is about?  What exactly is the
> >> question?
> >> Is it that it should be defaulted but isn't, or is shouldn't be
> >> defaulted but it is?  And on which element?  And in which DTD/XSD?
> >>
> >> And what's the answer to the question?
> 
> Colour me confused.  The DTD in the draft
> http://www.w3.org/TR/2008/WD-xlink11-20080331/#sample-dtd-appx has
> appropriate _FIXED_ values for xlink:type for each element it declares
> ('simple', 'extended', etc.).
> 
> The XML Schema in the draft is similar, but wrt the complexTypes it
> defines (it doesn't declare any elements at all).  This is also true
> of the revised version I sent to Norm last year, and of the
> simple-link-only version I sent to Norm in May.
> 
> Who raised this point, anyway?

I see it mentioned in our minutes first last July at
http://lists.w3.org/Archives/Public/public-xml-core-wg/2008Jul/0012
in minutes taken by Norm with Henry, Daniel, and Glenn in attendance.

I believe it is in response to the email thread at
http://lists.w3.org/Archives/Public/public-xml-core-wg/2008Jul/thread.ht
ml#msg5
which was started by you, Henry.

paul
Received on Tuesday, 16 June 2009 13:24:56 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 16 June 2009 13:24:56 GMT